Ask Your Question
0

TF Error while running AMCL (turtlebot). Waiting on transform from /base_link to /map to become available before running costmap.

asked 2013-04-17 00:10:37 -0600

prasanna.kumar gravatar image

updated 2013-04-21 10:04:35 -0600

Hi,

I have a world in gazebo(fuerte) with turtlebot in it and I have the map of the world too. After launching the world, when I try to launch the launch file described below, I get this warning:

[ WARN] [1366190909.527997203, 40.084000000]: Waiting on transform from /base_link to /map to become available before running costmap, tf error:

Launch File:

<launch>  
<!-- Run the map server -->
  <arg name="map_file" default="$(find turtlebot_navigation)/maps/willow-2010-02-18-0.10.yaml"/>
  <node name="map_server" pkg="map_server" type="map_server" args="$(arg map_file)" />

  <!--- Run AMCL -->
  <include file="$(find turtlebot_navigation)/config/amcl_turtlebot.launch" />

  <!--- Run Move Base -->
  <include file="$(find turtlebot_navigation)/config/move_base_turtlebot.launch" />

</launch>

I made the map of the environment with a turtlebot when I was using electric and I never used to get this warning in electric. After running this launch, when I do rosrun tf view_frames, /map frame does not show up in the list of frames at all. I referred to the following questions, but I am not able to get the catch. http://answers.ros.org/question/35844/help-with-navigation-error-transform-from-base_link-to-map/ http://answers.ros.org/question/9928/transform-from-base_link-to-map-navigation-stack-error/

What is the problem here ? Is there file I have to edit before running the launch or am I missing a step ?

Update:

image description

This is my TF tree (Pls save the image and zoom in for a clearer picture).

@Procópio Silveira Stein, I cannot visualise any data on rviz and I am unable to choose the initial pose in rviz. /map frame does not seem to exist at all.

I will try few more tricks and update shortly. Thanks,

Prasanna

edit retag flag offensive close merge delete

Comments

I did not understand your question properly. I guess map_server node is publishing the /map frame.

prasanna.kumar gravatar imageprasanna.kumar ( 2013-04-17 00:30:42 -0600 )edit

Sorry, I had some typos. As I told, I am not familiar with Gazebo. When using Stage, I think I had to choose an Initial Pose from Rviz to have AMCL started. Can you post an image of your TF tree, using "rosrun tf view_frames" , please?

Procópio gravatar imageProcópio ( 2013-04-17 03:46:53 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-04-18 09:56:47 -0600

prasanna.kumar gravatar image

I found the solution today, after 3 days. Actually, it was a bit annoying when I realized it. Here's the scoop.

In electric after launching gazebo-gui, I hade to run rosrun nodelet nodelet manager __name:=openni_manager before launching the AMCL and rviz but with fuerte that step was un-necessary till fuerte version 1.8.10. But in version 1.8.11 of fuerte the openni_manager nodelet is needed again. The AMCL stopped printing the warning immediately after I ran the openni_manager.

It's solved but I really want to know why things are so erratic!

edit flag offensive delete link more

Comments

I'm happy you managed to find a solution. cheers

Procópio gravatar imageProcópio ( 2013-04-19 04:03:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-17 00:10:37 -0600

Seen: 2,497 times

Last updated: Apr 21 '13