ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

groovy kinect No Image received

asked 2013-04-14 02:17:58 -0600

FfoNy gravatar image

updated 2016-10-24 08:59:43 -0600

ngrennan gravatar image

My laptop is (ASUS S46CM)

When I runlaunch turtlebot_rviz view-robot.launch

this is environment. (rviz)

Please help me.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted

answered 2013-06-07 06:02:45 -0600

FfoNy gravatar image

I solved my problem. Just install Ubuntu 12.04 (64bit),and usb 3.0 can work.

edit flag offensive delete link more

answered 2013-05-20 00:11:23 -0600

mmwise gravatar image

In order to properly debug this problem more information is required. Please post information on what version/release of ROS you are running as well as a full list of the launch files along with any error messages.

Looking at the original information. So far here are my guess as to what might be wrong:

  • I agree that it looks like the 3d_sensor.launch was not run. However I bet that when the 3dsensor.launch is run there is an error message that goes flying by that you are missing. Please scroll through the window and post a screenshot of any red/error text when launching.
  • Also another cause might be that you just have a revision of ROS that was broken, at one point in groovy I encountered a bug which you could not get camera data caused by openni, the solution is to do an apt-get update on ROS.
  • Are you running rviz remotely on desktop or locally on the turtlebot? Do you have your ROS IP set correctly? This might also be a problem.
edit flag offensive delete link more


OK. I will post screenshots later.

FfoNy gravatar image FfoNy  ( 2013-05-20 04:50:36 -0600 )edit

OS:Ubuntu 12.04LTS I launch rosversion ros........ it says <unversioned> This case is launch turtlebot_bring 3d_sensor.launch

FfoNy gravatar image FfoNy  ( 2013-05-20 22:16:54 -0600 )edit

I am running rviz locally on the turtlebot.

FfoNy gravatar image FfoNy  ( 2013-05-20 22:19:01 -0600 )edit

answered 2013-04-17 03:03:40 -0600

updated 2013-04-17 03:04:27 -0600

So, given all the previous comments, try the following solution :

go to avin2 drivers.

Unpack, select the ones for your platform. Then use the "./uninstall" script first. Then "./install".

Try to launch again ""roslaunch openni_launch openni.launch depth_registered:=true". In another terminal, do a "rostopic list", and /camera/rgb/image_color should have appeared.

You are now free to quit everyting, and use your own application :

roslaunch turtlebot_bringup 3dsensor.launch

then in another terminal

roslaunch turtlebot_rviz view-robot.launch

Let us know !

Ps : the solution comes from this topic

edit flag offensive delete link more


I download this but I don't know how to install..... Please tell you,thanks

FfoNy gravatar image FfoNy  ( 2013-04-17 22:18:58 -0600 )edit

and uninstall.......

FfoNy gravatar image FfoNy  ( 2013-04-17 22:37:26 -0600 )edit

answered 2013-04-14 15:49:36 -0600

updated 2013-04-14 15:51:18 -0600

Hi there

view-robot.launch only initializes rviz with the proper configuration to visualize Turtlebot's data. It does not start any of the sensors or other services.

If you want to visualize the images coming from the kinect, make sure that 3dsensor.launch is running:

roslaunch turtlebot_bringup 3dsensor.launch

and then you can launch view_robot.launch

I hope this helps.

edit flag offensive delete link more


sorry, I don't say I roslaunch turtlebot_bringup 3dsensor.launch then problem is still exist.

FfoNy gravatar image FfoNy  ( 2013-04-14 17:22:37 -0600 )edit

then the next thing I would check is if the Kinect is connected to a USB 3.0, because Kinect + USB 3.0 is still not very well supported. Make sure that your Kinect is connected to a USB 2.0 port

Martin Peris gravatar image Martin Peris  ( 2013-04-14 18:03:28 -0600 )edit

Left has a USB 3.0 port and right hase 2 USB 2.0 ports, I make sure kinect is connected to USB 2.0 port.

FfoNy gravatar image FfoNy  ( 2013-04-14 18:51:02 -0600 )edit

Did you try using "roslaunch openni_launch openni.launch" instead of 3dsensor.launch ?

CarolineQ gravatar image CarolineQ  ( 2013-04-15 00:10:09 -0600 )edit

This is running case

FfoNy gravatar image FfoNy  ( 2013-04-15 02:38:30 -0600 )edit

Can you retrieve images from the topic /camera/ir/image_raw ? or display the depth image on /camera/depth/image ?

Martin Peris gravatar image Martin Peris  ( 2013-04-15 14:27:34 -0600 )edit

No,i can't. How can I work this....... Thanks

FfoNy gravatar image FfoNy  ( 2013-04-15 15:13:38 -0600 )edit

Usb 3.0 is no problem with Ubuntu 12.10. First, be sure, by "roslaunch openni_launch openni.launch" that your kinect is correctly installed (do a "rostopic list" to check for '/camera/rgb/image_color' for example). Keep us updated of the outcome of this. Bests, Steph

Stephane.M gravatar image Stephane.M  ( 2013-04-15 20:11:06 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-04-14 02:17:58 -0600

Seen: 1,135 times

Last updated: Jun 07 '13