Ask Your Question
0

error compiling ompl_ros_interface tutorial (calling joint space planner)

asked 2013-04-10 16:01:27 -0500

ryann2k1 gravatar image

updated 2013-04-11 01:14:12 -0500

felix k gravatar image

Hi guys, I am experiencing problem when compiling the calling joint spcae planner. System running on ubuntu 12.04 with ros fuerte. Error message:

[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['ompl_tutorial_example']                   
[ rosmake ] Logging to directory /home/anshar/.ros/rosmake/rosmake_output-20130411-121509
[ rosmake ] Expanded args ['ompl_tutorial_example'] to:
['ompl_tutorial_example']
[rosmake-0] Starting >>> std_msgs [ make ]                                      
[rosmake-1] Starting >>> roslang [ make ]                                       
[rosmake-0] Finished <<< std_msgs  No Makefile in package std_msgs              
[rosmake-1] Finished <<< roslang  No Makefile in package roslang                
[rosmake-1] Starting >>> roscpp [ make ]                                        
[rosmake-6] Starting >>> rospy [ make ]                                         
[rosmake-6] Finished <<< rospy  No Makefile in package rospy                    
[rosmake-1] Finished <<< roscpp  No Makefile in package roscpp                  
[rosmake-6] Starting >>> ompl_tutorial_example [ make ]                         
[ rosmake ] All 37 linesmpl_tutorial_example: 2.2 s... [ 1 Active 4/5 Complete ]
{-------------------------------------------------------------------------------
  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
  [rosbuild] Building package ompl_tutorial_example
  [rosbuild] Including /opt/ros/fuerte/share/rospy/rosbuild/rospy.cmake
  [rosbuild] Including /opt/ros/fuerte/share/roscpp/rosbuild/roscpp.cmake
  [rosbuild] Including /opt/ros/fuerte/share/roslisp/rosbuild/roslisp.cmake
  -- Configuring done
  -- Generating done
  CMake Warning:
    Manually-specified variables were not used by the project:

      CMAKE_TOOLCHAIN_FILE


  -- Build files have been written to: /home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build
  cd build && make -j8 -l8
  make[1]: Entering directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  make[2]: Entering directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  make[3]: Entering directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  make[3]: Leaving directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  [  0%] Built target rospack_genmsg_libexe
  make[3]: Entering directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  make[3]: Leaving directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  [  0%] Built target rosbuild_precompile
  make[3]: Entering directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  make[3]: Leaving directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  make[3]: Entering directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  [100%] Building CXX object CMakeFiles/ompl_joint_goal.dir/src/ompl_joint_goal.o
  /home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/src/ompl_joint_goal.cpp:3:48: fatal error: motion_planning_msgs/GetMotionPlan.h: No such file or directory
  compilation terminated.
  make[3]: *** [CMakeFiles/ompl_joint_goal.dir/src/ompl_joint_goal.o] Error 1
  make[3]: Leaving directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  make[2]: *** [CMakeFiles/ompl_joint_goal.dir/all] Error 2
  make[2]: Leaving directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
  make[1]: *** [all] Error 2
  make[1]: Leaving directory `/home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/build'
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package ompl_tutorial_example written to:
[ rosmake ]    /home/anshar/.ros/rosmake/rosmake_output-20130411-121509/ompl_tutorial_example/build_output.log
[rosmake-6] Finished <<< ompl_tutorial_example [FAIL] [ 2.27 seconds ]          
[ rosmake ] Halting due to failure in package ompl_tutorial_example. 
[ rosmake ] Waiting for other threads to complete.
[ rosmake ] Results:                                                            
[ rosmake ] Built 5 packages with 1 failures.                                   
[ rosmake ] Summary output to directory                                         
[ rosmake ] /home/anshar/.ros/rosmake/rosmake_output-20130411-121509

I am referring to: http://www.ros.org/wiki/ompl_ros_interface/Tutorials/Calling%20the%20joint%20space%20planner

is the missing file part of the package in motion_planning_msgs? Looking forward to any assistance. Thanks

Ryan

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-04-11 01:16:39 -0500

felix k gravatar image

updated 2013-04-18 22:50:43 -0500

It error states it could not find that file. Is the motion_planning_msgs package in your ROS_PACKAGE_PATH?

rospack find motion_planning_msgs

As you can see in the output the compiler finds a reference to the old package at line 3 in the mentioned file:

  /home/anshar/fuerte_workspace/sandbox/ompl_tutorial_example/src/ompl_joint_goal.cpp:3:48: fatal error: motion_planning_msgs/GetMotionPlan.h: No such file or directory

So if your file actually looks different, your make is broken. For a dull test call make clean before.

edit flag offensive delete link more

Comments

it is not in my ros package, but some sources mentioned that motion_planning_msgs has changed to arm_navigation_msgs. GetMotionPlan.h does exist in arm_navigation_msgs. Yet, after changing, the compilation still produces the same error.

ryann2k1 gravatar image ryann2k1  ( 2013-04-16 15:16:00 -0500 )edit

I Just figure out that arm_navigations_msgs appear twice in my ros path:/opt/ros/fuerte/stacks/arm_navigation/arm_navigation_msgs/srv_gen/cpp/include/arm_navigation_msgs$, however it doesn't recognise the directory -> fatal error: arm_navigation_msgs/GetMotionPlan.h: No such file or directory

ryann2k1 gravatar image ryann2k1  ( 2013-04-16 22:55:32 -0500 )edit

Have you replaced every occurrence of motion_planning_msgs (manifest, that other include, CMakeLists if at all...) Why do you mean twice? The package-named directory inside msg_gen or srv_gen is correct, but of course shouldn't be in your ROS_PACKAGE_PATH itself.

felix k gravatar image felix k  ( 2013-04-17 00:28:58 -0500 )edit

Thanks for responding. I am following this tutorial: http://www.ros.org/wiki/ompl_ros_interface/Tutorials/Calling%20the%20joint%20space%20planner , I have replaced all the occurrence of motion_planning_msgs in my example_ompl_tutorials directory.any assistance would be appreciated

ryann2k1 gravatar image ryann2k1  ( 2013-04-17 15:22:28 -0500 )edit

I just reinstalled ros and re-do everything and managed to successfully compile it according to the tutorial. I decided to reinstall after trying sudo apt-get update my system and it reported some missing dependencies.Thank you for your respond.

ryann2k1 gravatar image ryann2k1  ( 2013-05-09 00:10:49 -0500 )edit

Glad you got it. Maybe apt-get install -f or apt-get dist-upgrade could have helped. Haven't thought about that.

felix k gravatar image felix k  ( 2013-05-13 04:02:10 -0500 )edit

I tried before reinstalling but didn't work.Thanks a lot felix for your follow up respond. :)

ryann2k1 gravatar image ryann2k1  ( 2013-05-20 21:55:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-10 16:01:27 -0500

Seen: 252 times

Last updated: Apr 18 '13