ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rqt_plot not plotting data

asked 2013-03-26 06:55:34 -0500

moallen gravatar image

updated 2014-03-29 04:54:45 -0500

130s gravatar image

Beginner Level Tutorial, 6. Understanding ROS Topics. Examples work as expected until I get to 1.5 Using rqt-plot. The graph shows up but I can't get data to plot (blank graph). Tried all previous steps 4 times but still no plot with x:y or theta. No errors are shown. Reload doesn't help. I'm using fuerte with ubuntu. What can I try? Thanks.

edit retag flag offensive close merge delete


I have this issue as well, using groovy in Ubuntu. Changing the topic name in the rqt_plot GUI doesn't change the graph, it stays blank.

Rebumble gravatar image Rebumble  ( 2013-04-24 07:44:53 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-03-26 16:29:09 -0500

130s gravatar image

Make sure you running turtlesim_node running, in order for necessary topics (/turtle1/pose/ in this case) to be published.

Btw however, I haven't been able either to specify topic x:y as an argument from commandline. You can work it around by giving the topic name on GUI's designated field.

Using ros-fuerte-rqt amd64 0.1.6-s1360620793~precise.

edit flag offensive delete link more



I had the same problem and was not able to specify a topic from command line. Shouldn't this be changed in the tutorial?

Michele Palmia gravatar image Michele Palmia  ( 2013-05-16 03:08:18 -0500 )edit

I opened an enhancement request. If you/someone could volunteer to modify the wiki I would appreciate it (right now I have no time to work on that).

130s gravatar image 130s  ( 2013-05-16 07:16:03 -0500 )edit

I edited the wiki to reflect the actual use of the tool.

Michele Palmia gravatar image Michele Palmia  ( 2013-05-17 04:02:52 -0500 )edit
130s gravatar image 130s  ( 2013-05-17 04:18:24 -0500 )edit

In groovy it works perfectly well to plot a pose with "rosrun rqt_plot rqt_plot /uav/0/pose/pose/position/x:y:z". So what exactly is not working?

TommyP gravatar image TommyP  ( 2013-05-27 23:08:10 -0500 )edit

@TommyP what does this command return dpkg -p ros-groovy-rqt-plot?

130s gravatar image 130s  ( 2013-05-28 00:01:59 -0500 )edit

Version: 0.2.16-0precise-20130419-1956-+0000

TommyP gravatar image TommyP  ( 2013-05-28 00:35:35 -0500 )edit

@TommyP make sure the name of the topic is exactly the full name that's published. In your case do you see `/uav/0/pose/pose/position` is published (check by `rostopic list`)?

130s gravatar image 130s  ( 2013-08-07 14:46:01 -0500 )edit

answered 2014-08-08 08:22:51 -0500

bit-pirate gravatar image

There is a way to get subplots working - not a very convenient one though. @dirk-thomas 's comment in this thread points in the right direction:

You can load multiple plugins/instances of a plugin into the same rqt window. The command provided in the comment didn't work for me, but you can do it manually.

Start rqt

$ rqt

Then on the top left select Plugins -> Visualization -> Plot to add a rqt_plot. Repeat this to add more plots.

Note that every plot is independent. For example, if you pause one, the other continues to run.

This does the trick for me. Hope it helps you, too!

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2013-03-26 06:55:34 -0500

Seen: 9,162 times

Last updated: Aug 08 '14