Ask Your Question
0

Can we merge $PATH and $ROS_PACKAGE_PATH???

asked 2013-03-26 05:18:56 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi,

I want to know if it is possible to add stuff in the $PATH variable to $ROS_PACKAGE_PATH? Actually i want to do this because i have already installed some debian packages on Ubuntu (11.1) which were required by the OpenHaptics toolkit (ver 3.0) but ROS can't find them. If i run the OpenHaptics example directly, it works. But when i try to run some OpenHaptics code through ROS, it doesn't.

Any help will be appreciated greatly.

Thanks.

Following are some additional details:

$ echo $PATH /opt/ros/electric/ros/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

and

$ROS_PACKAGE_PATH /home/tufail/electric_workspace/sandbox/phantom:/opt/ros/electric/stacks

The following Debian packages have already been installed but ROS can't find them:

freeglut3-dev
libdrm-dev
libexpat1-dev
libglw1-mesa
libmotif-dev
libncurses5-dev
libx11-dev
libxt-dev    
tcsh
x11proto-dri2-dev
x11proto-gl-dev
x11proto-print-dev
edit retag flag offensive close merge delete

Comments

Hello, can you update your question to address the following? How are you running the code "through ROS"? What error messages are you getting?

SL Remy gravatar imageSL Remy ( 2013-03-26 05:30:34 -0600 )edit

Can you clarify how ROS can't find the installed packages? Is there a specific compile error you're seeing, or does it only have trouble at runtime?

ahendrix gravatar imageahendrix ( 2013-03-26 07:08:12 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-26 08:41:21 -0600

tufail gravatar image

updated 2013-03-26 08:45:52 -0600

I have resolved it.

As the packages (dependencies) were already installed using Ubuntu Software Centre, so ROS didn't need to re-install them. I just removed those rosdep entries from the manifest file in package and built it again. It worked.

Thanks for your replies anyway. I appreciate it.

edit flag offensive delete link more
0

answered 2013-03-26 07:54:54 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello, thanks for your replies.

Actually i want to use the phantom_omni ROS package.

But when i want to rosmake or rosdep check the package, ROS says that it can't find the dependencies. But i remember i have installed all these packages one by one through Ubuntu Software Centre. Following is the output with me:

tufail@tufail-desktop:~/electric_workspace$ rosdep check phantom_omni
Failed to find rosdep libxt-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep x11proto-print-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libdrm-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep freeglut3-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep x11proto-gl-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libx11-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep x11proto-dri2-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep tcsh for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libncurses5-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libmotif-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libexpat1-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libglw1-mesa for package phantom_omni on OS:ubuntu version:oneiric
error in processing scripts ABORTING: Rosdeps [u'libxt-dev', u'x11proto-print-dev',
u'libdrm-dev', u'freeglut3-dev', u'x11proto-gl-dev', u'libx11-dev', u'x11proto
dri2-dev', u'tcsh', u'libncurses5-dev', u'libmotif-dev', u'libexpat1-dev', u'libglw1
mesa'] could not be resolved
Failed to find rosdep libxt-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep x11proto-print-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libdrm-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep freeglut3-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep x11proto-gl-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libx11-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep x11proto-dri2-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep tcsh for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libncurses5-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libmotif-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libexpat1-dev for package phantom_omni on OS:ubuntu version:oneiric
Failed to find rosdep libglw1-mesa for package phantom_omni on OS:ubuntu version:oneiric
The following rosdeps were not installed [u'libxt-dev', u'x11proto-print-dev', u'libdrm-dev', u'freeglut3-dev', u'x11proto-gl-dev', u'libx11-dev', u'x11proto-dri2-dev', u'tcsh', u'libncurses5-dev', u'libmotif-dev', u'libexpat1-dev', u'libglw1-mesa']
edit flag offensive delete link more

Comments

I am sorry the ROS output is not properly formatted. Its just messed up. I don't know how to make it appear more readable. I am new to ROS ;(

tufail gravatar imagetufail ( 2013-03-26 07:57:10 -0600 )edit
1

Unfortunately the developers of phantom_omni made it a bit complicated to use. Basically if all the drivers for PHANToM are installed and working properly you can remove all these system dependencies from the package.

Boris gravatar imageBoris ( 2013-03-26 18:29:33 -0600 )edit
1

Also, what features do you need? I made a fork of phantom_omni some time ago, but removed some functionality, i.e. 'manual' kinematics calculation as it was wrong and replaced it with the kinematics from the driver. So if you want to give it a try I can upload it to GitHub or similar.

Boris gravatar imageBoris ( 2013-03-26 18:36:11 -0600 )edit

Hi Boris,

I want use the Phantom Omni device for teleoperation. I want to try the pr2_omni_teleop package where the Cartesian position and velocity from Omni device is published to the PR2 robot and in return the force is fed back to it.

tufail gravatar imagetufail ( 2013-03-26 22:10:40 -0600 )edit

and yes you are right, doing the 'manual' kinematics calculation doesn't make any sense. I don't know why the transform from base to tool frame is calculated when you can easily get it through the OpenHaptics function call hdGetDoublev(HD_CURRENT_TRANSFORM, ... ). Similarly for the linear velocity.

tufail gravatar imagetufail ( 2013-03-26 22:17:15 -0600 )edit

I will try to improve the code as much as i can. I will welcome if you can share your code through GitHub.

Currently I am getting some errors while playing with the pr2_omni_teleop package. I will post another question about it if i get seriously stuck.

Thanks.

tufail gravatar imagetufail ( 2013-03-26 22:20:25 -0600 )edit

I am working on a similar setup, but going to generalize the package to make it work with other Phantoms, e.g. 6-DoF one. Regarding the velocity I believe there was a bug and driver always returns zeros. So position still has to be differentiated to calculate velocity.

Boris gravatar imageBoris ( 2013-03-26 22:26:49 -0600 )edit

I have already tried the same code with Phantom Premium 6-DoF. It works and nothing needs to be changed except the device name. But yes the code has much room for improvement. Any success on pr2_omni_teleop?

tufail gravatar imagetufail ( 2013-03-26 22:37:22 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-26 05:18:56 -0600

Seen: 156 times

Last updated: Mar 27 '13