ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Some problems about the ROS path

asked 2011-02-23 16:38:08 -0600

Yongqiang Gao gravatar image

updated 2014-01-28 17:09:13 -0600

ngrennan gravatar image


My ROS has been installed at /opt/ros/cturtles

/opt/ros/cturtle$ ls

it shows: jason ros setup.bash setup.zsh stacks

where the file of "jason" which I create, is to be contained myself packages.

Question1, could i create this file for including myself packages? I mean could i create this file under "cturtles" file, or "ros" file , or "stacks" file?

Question2,I create a package with 'roscreate-pkg', then I update my ros path.and the command is :

$ export ROS_PACKAGE_PATH=/opt/ros/cturtle/jason/:$ROS_PACKAGE_PATH

and then

$ rospack find ros_opencv   %ros_opencv is what i have created

but it shows [rospack] warning: trailing slash found in ROS_PACKAGE_PATH /opt/ros/cturtle/jason/ros_opencv

at the terminal, and the next time,I input the command

$ rospack find ros_opencv

it shows :[rospack] couldn't find package [ros_opencv] why?

Best regards

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2011-02-23 16:50:20 -0600

Chad Rockey gravatar image

updated 2011-02-23 16:51:18 -0600

So it looks like you have an extra trailing slash at the end of /opt/ros/cturtle/jason/. Try just using: export ROS_PACKAGE_PATH=/opt/ros/cturtle/jason:$ROS_PACKAGE_PATH

Also, two more things: you may want to not place your own packages in /opt/. It may be easier permission wise to place things in say: /home/jason/stacks

And don't forget that you can place the export command in your .bashrc (/home/your_name/.bashrc) so that you don't have to type it in every new terminal you open.

edit flag offensive delete link more

answered 2011-02-23 17:24:41 -0600

Yongqiang Gao gravatar image

Thanks to chadrockey, and i have move myself files under ~/stacks, and I also add "export ROS_PACKAGE_PATH=~/stacks:$ROS_PACKAGE_PATH" into /.bashrc as a results it works well.

I am new to ROS, thanks chadrockey again.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2011-02-23 16:38:08 -0600

Seen: 782 times

Last updated: Feb 23 '11