Ask Your Question
0

Broken dependencies in Fuerte

asked 2012-04-04 20:24:17 -0500

CaptainTrunky gravatar image

updated 2014-01-28 17:11:52 -0500

ngrennan gravatar image

Hi! I installed ros-fuerte-desktop-full beta yesterday using this manual. I'm using Ubuntu 11.10. Everything seems to be good, but when I try to compile my old project, I receive next messages.

manifest.xml contains next:

<package>
  <description brief="RobotVision">

     RobotVision

  </description>
  <author>crady</author>
  <license>BSD</license>
  <review status="unreviewed" notes=""/>
  <url>http://ros.org/wiki/RobotVision</url>
  <depend package="pcl"/>
  <depend package="pcl_ros"/>
  <depend package="roscpp"/>
  <depend package="sensor_msgs"/>
  <depend package="vosch"/>
</package>

What is wrong? I'm missing something? Project created and works on electric.

edit retag flag offensive close merge delete

Comments

What is your ROS_PACKAGE_PATH and other ROS environment settings? 'env | grep ROS'

tfoote gravatar imagetfoote ( 2012-04-05 07:51:00 -0500 )edit

Please answer Tully's question about ROS_PACKAGE_PATH.

joq gravatar imagejoq ( 2012-04-05 10:04:57 -0500 )edit

$ env | grep ROS

ROS_ROOT=/opt/ros/fuerte/share/ros

ROS_PACKAGE_PATH=/home/crady/ros:/opt/ros/fuerte/stacks

ROSLISP_PACKAGE_DIRECTORY=/opt/ros/fuerte/share/common-lisp/ros

ROS_MASTER_URI=http://localhost:11311

ROS_DISTRO=fuerte

ROS_ETC_DIR=/opt/ros/fuerte/etc/ros

CaptainTrunky gravatar imageCaptainTrunky ( 2012-04-05 10:13:08 -0500 )edit

Did appending ":/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros" to the end of your $ROS_PACKAGE_PATH work?

joq gravatar imagejoq ( 2012-04-06 03:11:15 -0500 )edit

Seems that this helps. Now it complains on really missing package, not "virtually". Thanks a lot!

CaptainTrunky gravatar imageCaptainTrunky ( 2012-04-07 01:52:57 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2012-04-05 02:27:21 -0500

joq gravatar image

updated 2012-04-05 10:56:11 -0500

Looks like you need the PCL library itself, now separately installed:

$ sudo apt-get install ros-fuerte-pcl

You can use the new rosdep script to make sure you install everything:

$ rosdep install RobotVision

UPDATE: my $ROS_PACKAGE_PATH contains all this:

/opt/ros/fuerte/stacks:/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros
edit flag offensive delete link more

Comments

I received next

rosdep install RobotVision All required rosdeps installed successfully

and from apt-get install

ros-fuerte-pcl is already the newest version. ros-fuerte-pcl set to manually installed.

Everything seems to be good, but does not compile.

CaptainTrunky gravatar imageCaptainTrunky ( 2012-04-05 07:35:55 -0500 )edit

That sounds like a new question. Please ask it separately with error messages, etc.

joq gravatar imagejoq ( 2012-04-05 09:34:22 -0500 )edit

I didn't understand you, what about question?

rosdep and apt-get install works fine, they say that all dependencies for my project (like pcl) already installed (and it's true - I can see libs and headers in /opt/fuerte). But I still have error with them from my first post.

CaptainTrunky gravatar imageCaptainTrunky ( 2012-04-05 09:49:59 -0500 )edit
1

answered 2012-04-09 16:28:55 -0500

tfoote gravatar image

You need /opt/ros/fuerte/stacks and /opt/ros/fuerte/share in your ROS_PACKAGE_PATH like this:

/opt/ros/fuerte/share:/opt/ros/fuerte/stacks
edit flag offensive delete link more

Comments

Mine also contains /opt/ros/fuerte/share/ros ($ROS_ROOT). Not sure what is adding that. Is it unnecessary?

joq gravatar imagejoq ( 2012-04-10 05:19:43 -0500 )edit
0

answered 2012-04-04 21:12:39 -0500

AHornung gravatar image

There may still be old build artifacts around from building in electric. Have you tried running "make clean" before running "make"? You can do that recursively with "rosmake --pre-clean RobotVision".

edit flag offensive delete link more

Comments

Yes, I tried this. But it did not help. I receive the same errors.

CaptainTrunky gravatar imageCaptainTrunky ( 2012-04-04 22:34:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-04 20:24:17 -0500

Seen: 410 times

Last updated: Apr 09 '12