Ask Your Question
0

Error in finding the package

asked 2011-12-09 02:57:40 -0500

dbs12 gravatar image

updated 2014-01-28 17:10:58 -0500

ngrennan gravatar image

Hi.. For following command: echo $ROS_PACKAGE_PATH

Output: /opt/ros/electric/stacks

Change directory: cd ~/ros_workspace

Then: roscreate-pkg beginner_tutorials std_msgs rospy roscpp

WARNING: current working directory is not on ROS_PACKAGE_PATH! Please update your ROS_PACKAGE_PATH environment variable. I don't know why??

How do I change it? I follow all the instruction in previous section of setting environmental variable where I get proper output as mentioned. But i think there is still something very basic going wrong, which I am not able to figure out..because I am new at Ubuntu.

After package is created, when i try to find: rospack find beginner_tutorials

message : rospack couldn't find beginner_tutorials.

I am getting this error from long time..and not able to find the solution!! Please help. Is it possible for real time help?(on gmail, yahoo, skype..etc)

Thank you. Regards.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-12-09 03:09:34 -0500

DimitriProsser gravatar image

updated 2011-12-09 03:10:48 -0500

You need to add your ros_workspace to your ROS_PACKAGE_PATH. This can be done in your bashrc file. For a short, one-line solution enter the following into the commandline:

echo -e "\nexport ROS_PACKAGE_PATH=~/ros_workspace:$ROS_PACKAGE_PATH\n" >> ~/.bashrc

Then, in order to see the changes, you must remember to source your bashrc. (This only needs to be done on any terminals already open. Any new terminals you open henceforth will already be all set.)

source ~/.bashrc
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-09 02:57:40 -0500

Seen: 948 times

Last updated: Dec 09 '11