Ask Your Question
0

Rosmake pi_tracker error, needs nite

asked 2013-03-08 15:43:09 -0500

Zab gravatar image

updated 2013-03-08 15:43:48 -0500

Hello,

While attempting to use "rosmake pi_tracker" I get an error saying that I need to have nite on the system to compile pi_tracker. After a quick search of the wiki it seems that nite is no longer in the works. How can I compile pi_tracker without the nite package? Is there a workaround for this as I would not like to uninstall the working packages/drivers.

Installed:

ubuntu 12.04 x64

fuerte

openni drivers (openni-bin-dev-linux-x64-v1.5.4.0)

nite (nite-bin-dev-linux-x64-v1.5.2.21

I can run openni_launch and openni_tracker with rviz and get input as well as run the sample programs that come with the drivers/middleware. Thank you for your time.

The error:

  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
  [rosbuild] Building package pi_tracker
  Failed to invoke /opt/ros/fuerte/bin/rospack deps-manifests pi_tracker
  [rospack] Error: package/stack pi_tracker depends on non-existent package nite


  CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:129 (message):


    Failed to invoke rospack to get compile flags for package 'pi_tracker'.
    Look above for errors from rospack itself.  Aborting.  Please fix the
    broken dependency!

  Call Stack (most recent call first):
    /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack)
    CMakeLists.txt:12 (rosbuild_init)


  -- Configuring incomplete, errors occurred!
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package pi_tracker written to:
[ rosmake ]    /home/zab/.ros/rosmake/rosmake_output-20130308-212657/pi_tracker/build_output.log
[rosmake-1] Finished <<< pi_tracker [FAIL] [ 0.58 seconds ]                    
[ rosmake ] Halting due to failure in package pi_tracker.
[ rosmake ] Waiting for other threads to complete.
[ rosmake ] Results:                                                           
[ rosmake ] Built 37 packages with 1 failures.                                 
[ rosmake ] Summary output to directory                                        
[ rosmake ] /home/zab/.ros/rosmake/rosmake_output-20130308-212657
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-09 03:43:23 -0500

Pi Robot gravatar image

Hi @Zab -- Looks like the recent update to the OpenNI drivers requires some changes. I have updated the pi_tracker package by removing the dependency on NITE and I added a new launch file called skeleton_fuerte_new_openni.launch that loads a new config file compatible with the new drivers. To get it working, follow these steps

$ roscd pi_tracker
$ make clean
$ svn update
$ rosmake
$ roslaunch pi_tracker skeleton_fuerte_new_openni.launch

--patrick

edit flag offensive delete link more

Comments

Thank you! pi_tracker will launch but now I get a new error.

ERROR: cannot launch node of type [pi_tracker/skeleton_tracker]: can't locate node [skeleton_tracker] in package [pi_tracker]

Zab gravatar imageZab ( 2013-03-09 06:38:37 -0500 )edit

@Zab - Did you run 'make clean' and 'rosmake'? The skeleton_tracker node is a C++ file (and some headers) that has to be built by rosmake.

Pi Robot gravatar imagePi Robot ( 2013-03-09 11:09:04 -0500 )edit

I ran the commands but I still get an error that says nite is a dependency. Is this normal?

[rosbuild] Building package pi_tracker Failed to invoke /opt/ros/fuerte/bin/rospack deps-manifests pi_tracker

[rospack] Error: package/stack pi_tracker depends on non-existent package nite

Zab gravatar imageZab ( 2013-03-09 11:26:10 -0500 )edit

Hmm. That's odd--sounds like the svn update command didn't work. How about deleting the pi_tracker directory (or move it out of your ROS_PACKAGE_PATH) and then just check out the package from scratch.

Pi Robot gravatar imagePi Robot ( 2013-03-09 11:43:18 -0500 )edit

Deleted and redownloaded pi_tracker, nite is still listed in the manifest.xml Here is the rep where I am getting it from: svn http://pi-robot-ros-pkg.googlecode.com/svn/trunk/pi_tracker

Zab gravatar imageZab ( 2013-03-09 11:51:28 -0500 )edit

So it is! My apologies--I have no idea how it got back in there since that's the first thing I removed earlier today. Anyway I just committed another update then downloaded it and verified that nite has now been removed from manifest.xml.

Pi Robot gravatar imagePi Robot ( 2013-03-09 11:55:34 -0500 )edit

[ 81%] Building CXX object CMakeFiles/skeleton_tracker.dir/src/skeleton_tracker.o In file included from /home/zab/pi_tracker/src/skeleton_tracker.cpp:15:0: /home/zab/pi_tracker/src/KinectController.h:5:26: fatal error: XnCppWrapper.h: No such file or directory

Zab gravatar imageZab ( 2013-03-09 12:00:11 -0500 )edit

I have the openni/nite drivers/headers in /usr/include/ni and /usr/include/nite

I don't understand why pi_tracker can't seem to find them.

Zab gravatar imageZab ( 2013-03-09 12:01:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-08 15:43:09 -0500

Seen: 241 times

Last updated: Mar 09 '13