Ask Your Question
1

TF_NO_FRAME_ID: Ignoring transform with child_frame_id

asked 2011-09-22 19:51:16 -0500

ychua gravatar image

updated 2014-01-28 17:10:25 -0500

ngrennan gravatar image

Hi, I've tried the pi_tracker package. I have no errors running skeleton.launch and tracker.launch. However, when I rosrun rviz, I met the following errors

edit retag flag offensive close merge delete

Comments

[ERROR] [1316763642.701371303]: TF_NO_FRAME_ID: Ignoring transform with child_frame_id "/right_shoulder" from authority "/skeleton_tracker" because frame_id not set [ERROR] [1316763642.701422097]: TF_NO_FRAME_ID: Ignoring transform with child_frame_id "/right_elbow" from authority "/skeleton_tracker" because frame_id not set [ERROR] [1316763642.701475147]: TF_NO_FRAME_ID: Ignoring transform with child_frame_id "/right_hand" from authority "/skeleton_tracker" because frame_id not set
ychua gravatar image ychua  ( 2011-09-22 19:54:24 -0500 )edit
The robot model in the rviz has no errors. I've also changed the 'skel_to_joint_map' parameter in the tracker_params.yaml, to correspond with the joint names with my robot urdf model. I also changed the line in the 'self.cmd_joints.position[self.cmd_joints.name.index('myRobot_jointName')] = right_shoulder_lift_angle' in the tracker_joint_controller.py to my robot urdf's joint name. Is there anywhere else I need to change in the code? Thanks a lot!
ychua gravatar image ychua  ( 2011-09-22 19:55:11 -0500 )edit
In rviz, in TF display. I got status: warning "/openni_camera: No transform from [/openni_camera] to frame[/world] /openni_depth_frame: No transform from [/openni_depth_frame to frame[/world]" etc....
ychua gravatar image ychua  ( 2011-09-22 20:14:34 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-27 10:08:00 -0500

tfoote gravatar image

You need to change the fixed frame and target frame to something connected in rviz. See the user guide

edit flag offensive delete link more
1

answered 2020-07-14 15:54:07 -0500

youssef desouky gravatar image

updated 2020-07-15 14:48:17 -0500

jayess gravatar image

check your urdf: my case was

<joint
    name="right_forward_steering_joint"
    type="continuous">
    <origin
      xyz="-0.71499 0.65792 0.2505"
      rpy="1.5708 0 0" />
    <parent
      link="base_link" />
    <child
      link="right_forward_steering" />
    <axis
      xyz="0 0 0" />
</joint>

the xyz axis was (0 0 0), i solved it by adding 1 in the axis of rotation so it will be

<axis xyz="0 1 0" />
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-22 19:51:16 -0500

Seen: 2,124 times

Last updated: Jul 15 '20