Ask Your Question
0

Help with General ROS query [closed]

asked 2013-02-17 15:32:15 -0500

nemesis gravatar image

updated 2013-02-17 16:54:06 -0500

joq gravatar image

I am trying to communicate ROS (on a virtual machine) with Optitrack (on a separate computer, Windows) and there have been some suggestions as to what might help.

I am completely new to ROS and Linux systems and the documentations for packages are really really disappointing. I have tried to look up on how to download or build packages which are not on the wiki, tried to understand what any particular package can do and how to go about carrying out a task, but nothing has been helpful. I am sure I am not smart enough as you all might be but I have spent a lot of time trying to understand how to work with ROS and failed miserably at it.

Can anyone please guide me towards some (preferably general) tutorials on how to go about using ROS or certain packages in it so that I can get a better idea about it all?? Like I am trying to use "gt-ros-pkg " to use "ros_vrpn_client" via that for my task and something explaining how it can be done or to point me in the right direction?

I apologize for any rudeness, I am just frustrated 'cause of not being able to work it out properly. If I am missing something which has already been explained before, then I would gladly accept any criticism for my post above and would appreciate it if anyone could guide me in the right direction.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by tfoote
close date 2013-02-21 07:07:18

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-02-17 16:53:10 -0500

joq gravatar image

updated 2013-02-17 16:56:43 -0500

I am sorry for your frustration. Please note that, while valid, this is really not a general ROS query.

Many organizations throughout the world develop code using the ROS framework. The authors of ros_vrps_client do not seem to have released their package using any of the normal ROS mechanisms. So, the answer to your reasonable question is not apparent to me or (probably) most other ROS users.

If you can figure out who maintains this package, you should try to contact them directly. I took the liberty of tagging your question, hoping that those developers may be more likely to see it.

UPDATE: There seems to be more information on the Georgia Tech repository here.

edit flag offensive delete link more

Comments

Try contacting some of the people mentioned here: http://code.google.com/p/gt-ros-pkg/

joq gravatar imagejoq ( 2013-02-18 07:37:21 -0500 )edit
1

answered 2013-02-18 09:07:59 -0500

nemesis gravatar image

updated 2013-02-21 07:10:47 -0500

@joq - Thank you for your reply. I know it's not a valid query at all, but I was a bit bugged trying to figure it out. I already checked the link you mentioned before but again nothing concrete on their website. Nevertheless, I will give it a go again and I will try contacting some of the people there too. Once again, thank you so much. If I am able to find something concrete I will post it as a reply here.

@joq - I finally was able to figure it out. I have posted how I managed to make it work in my other post - "Communication between Ros and Optitrack" (I am not sure how to post the link here, not enough karma points I think)

Link is in the comments by @tfoote

edit flag offensive delete link more

Comments

Thank you @tfoote!

nemesis gravatar imagenemesis ( 2013-02-21 07:09:55 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2013-02-17 15:32:15 -0500

Seen: 139 times

Last updated: Feb 21 '13