ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Help with bullet and vrpn_client on Hyrdro on Ubuntu 12.04

asked 2014-12-11 12:53:07 -0500

TheHenshinger gravatar image

Hello, I am having to upgrade to hydro and in the process of getting my enviroment set up I ran into a stumbling block. ROS_VRPN_Client requires bullet3. After downloading bullet3 and making it I still get an erros when trying to run ROSMAKE on vrpn_client. This is the error I keep getting.

package/stack 'ros_vrpn_client' depends on non-existent package 'bullet' and rosdep claims that it is not a system dependency. Check the ROS_PACKAGE_PATH or try calling 'rosdep update

I understand why it wont compile, I need Bullet but the problem is I have downloaded it and have followed the steps by bullet to get it compiled. The question is, where am I doing things wrong at?

Any help will be appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-12-11 18:22:35 -0500

ahendrix gravatar image

There is a rosdep key for bullet which is defined on Precise. You should be able to resolve it if you run rosdep update.

That said, it looks like the packaged version of bullet on 12.04 is version 2.8, which isn't the version you want. In that case, you should probably just remove the dependency on bullet from your manifest.xml altogether.

edit flag offensive delete link more


hmmm, I ran rosdep update with no luck.

How will removing the dependency in the manifest.xml file fix the problem?

TheHenshinger gravatar image TheHenshinger  ( 2014-12-19 14:23:09 -0500 )edit

Question Tools

1 follower


Asked: 2014-12-11 12:52:20 -0500

Seen: 142 times

Last updated: Dec 11 '14