Ask Your Question
0

rosws not adding workspace directory to ROS_PACKAGE_PATH

asked 2013-02-12 12:30:53 -0600

w1res gravatar image

updated 2014-01-28 17:15:12 -0600

ngrennan gravatar image

Hi,

I am doing the setup tutorial on the ros website (not allowing me to post links...) I'm running a fresh install of the Ubuntu 12.04 ROS image from NooTriX in VirtualBox right now.

My problem is on section 4.2 of the tutorial where it tells you to do:

rosws set ~/fuerte_workspace/sandbox

I am running groovy and made a different directory, so I did:

rosws set ~/groovy_workspace/sandbox

The error I get is:

viki@ROS:~$ rosws set ~/groovy_workspace/sandbox
ERROR in config: Command requires a target workspace.viki@ROS:~$

Does anyone know why this is happening? I've already done:

source /opt/ros/groovy/setup.bash

and

rosws init ~/fuerte_workspace /opt/ros/fuerte

and

source /home/viki/groovy_workspace/setup.bash

When I look at my ROS_PACKAGE_PATH, all I see is

:/opt/ros/groovy/share:/opt/ros/groovy/stacks

So I am guessing something is wrong with rosws adding the right directories to the ROS_PACKAGE_PATH. Does anyone have any ideas on what I am doing wrong?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-02-12 13:32:00 -0600

jbohren gravatar image

updated 2013-02-12 14:30:36 -0600

There's a bug in rosws when used with groovy that makes it harder to roscd without arguments to get to your workspace. Instead, you need to cd ~/groovy_workspace and then you can execute rosws set.

edit flag offensive delete link more

Comments

It seems like this makes rosws set work, but it seems like the ROS_WORKSPACE still remains unset.

w1res gravatar imagew1res ( 2013-02-14 17:11:52 -0600 )edit
1

Yes, you will need to manually export ROS_WORKSPACE until the bugfix gets out through the debian packages.

jbohren gravatar imagejbohren ( 2013-02-14 18:27:22 -0600 )edit
1

answered 2013-02-13 02:28:56 -0600

KruseT gravatar image

After you run

 rosws init /home/viki/groovy_workspace /opt/ros/groovy
 source /home/viki/groovy_workspace/setup.bash

what you should get is:

$ echo $ROS_WORKSPACE
/home/viki/groovy_workspace
$ echo ROS_PACKAGE_PATH
/opt/ros/groovy/share:/opt/ros/groovy/stacks

due to bug already fixed but not released yet, ROS_WORKSPACE is not set. See: http://answers.ros.org/question/54871/no-ros_workspace-set-error/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-12 12:30:53 -0600

Seen: 1,571 times

Last updated: Feb 13 '13