ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Joy node doesn't work well [closed]

asked 2013-01-19 23:34:54 -0600

updated 2013-01-20 03:59:05 -0600

Hi everybody!

I am trying to use an Xbox joystick with the joy node in a virtual machine. Although I've checked the correct joystick signals reception as shown in (link text) with sudo jstest /dev/input/js1; I've changed correctly the permissions; and I've set the ros param to the correct device (js1), but the node has problems to publish the data. If I run the test as the tutorial tells, it takes some minutes before the first rostopic echo /joy received. Once I receive the echo, the values seems to be correct. This problem increases when I launch that joy node with a several other nodes, in that case, I never get the echo response of the /joy topic.

I am running Ubuntu 12.04LTS with ROS fuerte on a virtual machine using VirtualBox, and It doesn't seems to have any processor, I/O, or RAM problems (I run it together with Gazebo, rviz, etc.).

Thank you!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Àngel - IRI
close date 2013-01-22 05:48:20


When you say it doesn't seem to have any processor, I/O or RAM problems, you mean nothing else is slow? If all that is happening is the /joy topic takes long to get published to, I would assume it is a problem of hardware virtualization and/or excessive swapping. Could you try it outside the VM?

georgebrindeiro gravatar image georgebrindeiro  ( 2013-01-20 02:58:51 -0600 )edit

Testing the joystick with a test like "jstest", running on the virtual machine, everything works fine. Using ROS, everything seems to work fine, even gazebo and graphic rendering programs. The problem starts using /joy node. (Other nodes or programs work fine running at the same time than /joy).

Àngel - IRI gravatar image Àngel - IRI  ( 2013-01-20 03:56:32 -0600 )edit

1 Answer

Sort by » oldest newest most voted

answered 2013-01-22 05:47:34 -0600

Finally I got the solution without finding the failure...

I've reinstalled the whole system again and now it seems to work.

edit flag offensive delete link more


In order to change the ros param, you have to go to the xbox360_teleop.launch and add < param name="dev" value="/dev/input/js1"/ > to the joy node. <node pkg="joy" type="joy_node" name="joystick"/>

tlanglot gravatar image tlanglot  ( 2014-04-09 02:24:40 -0600 )edit

The question was closed more than one year ago. Thanks.

Àngel - IRI gravatar image Àngel - IRI  ( 2014-04-18 00:06:48 -0600 )edit

Question Tools


Asked: 2013-01-19 23:34:54 -0600

Seen: 1,703 times

Last updated: Jan 22 '13