Ask Your Question
0

[camera_nodelet_manager-1] process has died error with kinect

asked 2013-02-10 02:05:12 -0500

ap gravatar image

updated 2016-10-24 09:10:44 -0500

ngrennan gravatar image

i get the error below when i run: roslaunch openni_launch openni.launch depth_registration:=true

nodelet: /usr/include/boost/smart_ptr/shared_ptr.hpp:412: boost::shared_ptr<t>::reference boost::shared_ptr<t>::operator() const [with T = xn::NodeInfo, boost::shared_ptr<t>::reference = xn::NodeInfo&]: Assertion `px != 0' failed. [camera_nodelet_manager-1] process has died [pid 9117, exit code -6, cmd /opt/ros/fuerte/stacks/nodelet_core/nodelet/bin/nodelet manager __name:=camera_nodelet_manager __log:=/home/bot/.ros/log/3dd4e5a0-7388-11e2-8705-00187d252393/camera_nodelet_manager-1.log]. log file: /home/bot/.ros/log/3dd4e5a0-7388-11e2-8705-00187d252393/camera_nodelet_manager-1.log

please let me know how to correct- thanks

edit retag flag offensive close merge delete

Comments

using openni.launch so tried the killallXnSensorServer cmd. it worked. thank you.

ap gravatar image ap  ( 2013-02-11 00:51:07 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2013-02-10 14:29:39 -0500

Try typing this command in the same terminal where you get this error killall XnSensorServer. then try launching the node again. If the process dies again, ctrl+c and then type the killall command again (it should say no processes found). Then try launching the node again.

edit flag offensive delete link more

Comments

I had the same nodelet-manager dying error and this worked straight away for me. Thanks. It would be helpful for me if you also pointed me to why this worked.

shray gravatar image shray  ( 2013-06-08 10:36:29 -0500 )edit

I'm glad it worked for you. I am not exactly sure why it works. It just does :)

K_Yousif gravatar image K_Yousif  ( 2013-06-23 02:11:24 -0500 )edit

Like @ayush_dewan said about memory allocation. When you don't shut down properly, then you have multiple processes trynna access the camera...hence it crashes.

Pototo gravatar image Pototo  ( 2016-09-28 18:36:12 -0500 )edit

You can reproduce the error by launch and shutting down over and over, till you notice that the Depth camera light is still on, even if you've shut down your openni nodes/nodeleds

Pototo gravatar image Pototo  ( 2016-09-28 18:37:36 -0500 )edit
0

answered 2013-02-10 03:12:20 -0500

Looking at the error, the problem seems to be with memory allocation, you are accessing an unallocated memory which is causing code to crash. Are using kinect.launch file???Try using openni.launch file that comes with openni_launch package.

edit flag offensive delete link more

Comments

You are right on the memory allocation thingy.

Pototo gravatar image Pototo  ( 2016-09-28 18:35:08 -0500 )edit
0

answered 2016-09-28 18:48:08 -0500

Pototo gravatar image

updated 2016-09-28 18:49:29 -0500

One ROS runtime work around (at least it works in Openni2) is this in the next order (ideally in your Class destructor, or at the end of your main function before the program ends) :

void StreamingClass::~StreamingClass()
{
    ros::spinOnce();
    /// close streaming
    if (color_video_stream_.isValid() == true)
      color_video_stream_.stop();
    if (depth_video_stream_.isValid() == true)
       depth_video_stream_.stop();

     /// detroy video streaming objects as good practice,
     if (color_video_stream_.isValid() == true)
        color_video_stream_.destroy();
     if (depth_video_stream_.isValid() == true)
        depth_video_stream_.destroy();

     if (camera_device_.isValid() == true)
       camera_device_.close();
     nite::NiTE::shutdown();
     openni::OpenNI::shutdown();
}

Do it in that order, and that should take care of the problem, and will always shutdown the camera software. One thing though, if your camera nodelet had crashed right before trying this code, then unplug and plug the camera back in. Or better yet, restart your computer!!!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-10 02:05:12 -0500

Seen: 4,575 times

Last updated: Sep 28 '16