Ask Your Question
0

How to change the kinect sensor view in RViz

asked 2018-03-19 01:49:15 -0500

Nitin gravatar image

updated 2018-03-19 02:11:39 -0500

Hello,

I am using kinect sensor for object recognition. Followed the below steps to see kinect sensor view in RViz.

  1. Connected the kinect sensor to my desktop.
  2. Ran "roslaunch openni_launch openni.launch"
  3. Ran "rosrun rviz rviz" and Set the Fixed Frame (in Global Options, Displays window) to /camera_depth_optical_frame. Added a PointCloud2 display and set the topic to /camera/depth/points.
  4. Ran "rosrun rqt_reconfigure rqt_reconfigure" and then selected /camera/driver from the drop-down menu and enabled the depth_registration checkbox.

The camera view in RViz is not proper according to the plane. It is showing upwards. Please let me know, how to change the settings to make the view proper. The expected view should be link text

Platfrom: Ubuntu 16.04, ROS Kinetic

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-03-19 03:01:48 -0500

gvdhoorn gravatar image

depth_optical_frame has z+ pointing forward (ie: into the world). As Rviz global frame has z+ upwards (ie: out of the xy plane), your pointcloud is projected "onto the ceiling". You'll have to publish a transform between your Fixed Frame and (most likely) the camera_link to change this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-19 01:49:15 -0500

Seen: 237 times

Last updated: Mar 19 '18