Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to change the kinect sensor view in RViz

Hello,

I am using kinect sensor for object recognition. Followed the below steps to see kinect sensor view in RViz.

  1. Connected the kinect sensor to my desktop.
  2. Ran "roslaunch openni_launch openni.launch"
  3. Ran "rosrun rviz rviz" and Set the Fixed Frame (in Global Options, Displays window) to /camera_depth_optical_frame. Added a PointCloud2 display and set the topic to /camera/depth/points.
  4. Ran "rosrun rqt_reconfigure rqt_reconfigure" and then selected /camera/driver from the drop-down menu and enabled the depth_registration checkbox.

The camera view in RViz is not proper according to the plane. It is showing upwards. Please let me know, how to change the settings to make the view proper. The expected view should be link text

Platfrom: Ubuntu 16.04, ROS Kinetic

How to change the kinect sensor view in RViz

Hello,

I am using kinect sensor for object recognition. Followed the below steps to see kinect sensor view in RViz.

  1. Connected the kinect sensor to my desktop.
  2. Ran "roslaunch openni_launch openni.launch"
  3. Ran "rosrun rviz rviz" and Set the Fixed Frame (in Global Options, Displays window) to /camera_depth_optical_frame. Added a PointCloud2 display and set the topic to /camera/depth/points.
  4. Ran "rosrun rqt_reconfigure rqt_reconfigure" and then selected /camera/driver from the drop-down menu and enabled the depth_registration checkbox.

The camera view in RViz is not proper according to the plane. It is showing upwards. Please let me know, how to change the settings to make the view proper. The expected view should be link text

Platfrom: Ubuntu 16.04, ROS Kinetic