Ask Your Question
0

camera_calibration package not detected and cannot locate rosdep definition for sensor_msgs

asked 2013-05-13 22:53:54 -0600

sai gravatar image

updated 2016-10-24 08:35:02 -0600

ngrennan gravatar image

Hi,

ubuntu 12.04 and ROS Fuerte

I downloaded the camera_calibration package using

git clone https://github.com/ros-perception/image_pipeline.git

When I do

rosdep install camera_calibration

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: camera_calibration: Cannot locate rosdep definition for [sensor_msgs]

rosmake camera_calibration

[ rosmake ] rosmake starting...
[ rosmake ] Packages requested are: ['camera_calibration']
[ rosmake ] Logging to directory /home/sai/.ros/rosmake/rosmake_output-20130514-164830 [ rosmake ] Expanded args ['camera_calibration'] to: ['camera_calibration']
[rosmake-0] Starting >>> opencv2 [ make ]
[rosmake-1] Starting >>> catkin [ make ]
[rosmake-0] Finished <<< opencv2 ROS_NOBUILD in package opencv2
[rosmake-1] Finished <<< catkin ROS_NOBUILD in package catkin No Makefile in package catkin [rosmake-6] Starting >>> camera_calibration [ make ]
[rosmake-6] Finished <<< camera_calibration ROS_NOBUILD in package camera_calibration No Makefile in package camera_calibration [ rosmake ] Results:
[ rosmake ] Built 3 packages with 0 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/sai/.ros/rosmake/rosmake_output-20130514-164830
sai@sai-HP-EliteBook-8460w:~/fuerte_workspace$

finally when i do roscd camera_calibration

roscd: No such package/stack 'camera_calibration'

*There is no issue with sensor_msgs and is working well

Any help on how to solve these issues and get camera_calibration to work.

edit retag flag offensive close merge delete

Comments

This means ROS_PACKAGE_PATH is not set properly and hence ROS is unable to locate sensor_msgs and camera_calibration packages. Are you using a ros workspace or are you installing in some directory. In the latter case, are you setting the ROS_PACKAGE_PATH to include that directory as well?

mhariharasudan gravatar imagemhariharasudan ( 2013-05-13 23:17:23 -0600 )edit

Hi, I am using ROS workspace and am able to roscd to sensor_msgs and all the issues are solved with camera_calibration...Only one thing is left..when I do rosdep install camera_calibration it says camera_calibration: Cannot locate rosdep definition for [sensor_msgs]

sai gravatar imagesai ( 2013-05-14 23:35:26 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-05-14 04:14:35 -0600

joq gravatar image

It will be much simpler to just install the Ubuntu package:

$ sudo apt-get install ros-fuerte-image-pipeline
edit flag offensive delete link more

Comments

Hi, I tried this and now I am struck with one thing .when I do rosdep install camera_calibration it says camera_calibration: Cannot locate rosdep definition for [sensor_msgs]

sai gravatar imagesai ( 2013-05-14 23:36:32 -0600 )edit
2

The point of using apt-get was to avoid building image-pipeline from source. Common messages should have been installed automatically, they are a dependency. You should not need that rosdep install.

joq gravatar imagejoq ( 2013-05-15 06:29:31 -0600 )edit

@sai@joq Hey. I have the same problem and it isn't yet solved. For "sudo apt-get install camera_calibration", I am getting "Unable to locate package camera_calibration"

For "sudo apt-get install ros-fuerte-image-pipeline", I am getting Unable to locate package ros-fuerte-image-pipeline

Sulphur gravatar imageSulphur ( 2017-09-12 09:40:06 -0600 )edit

This answer dates back to 2013. ROS Fuerte is no longer supported. Substitute the name of the ROS version you are actually running.

joq gravatar imagejoq ( 2017-10-03 15:31:58 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-13 22:53:54 -0600

Seen: 1,894 times

Last updated: May 14 '13