Ask Your Question
0

openni_launch problems with kinect and asus, electric and fuerte.

asked 2012-07-13 07:20:21 -0500

punching gravatar image

updated 2016-10-24 09:02:17 -0500

ngrennan gravatar image

I've tried getting openni_launch to work on Ubuntu 12.04 with fuerte and a Kinect, also on 11.10 with electric and Kinect and on 11.10 with an Asus Xtion Pro Live and now on a second computer running 11.10, electric and the Asus camera. I'm convinced that there's got to be something wrong with the package. I've followed the instructions to the letter. Latest attempt with 11.10, electric and Asus Xtion.

Are there known problems? I've spent probably 40 hours trying to get it working and hired an experienced ROS developer who has probably 15-20 hours into trying to get it working. Are there known problems with it? Has the project been abandoned?

rosrun openni_launch openni.launch
[rosrun] Couldn't find executable named openni.launch below /opt/ros/electric/stacks/openni_kinect/openni_launch
[rosrun] Found the following, but they're either not files, 
[rosrun] or not executable:
[rosrun]   /opt/ros/electric/stacks/openni_kinect/openni_launch/launch/openni.launch
chris@chris-VirtualBox:/opt/ros/electric/stacks/openni_kinect$ 

rosmake openni_kinect --rosdep-install
[ rosmake ] Packages requested are: ['openni_kinect']                           
[ rosmake ] Logging to directory/home/chris/.ros/rosmake/rosmake_output-20120713-101739
[ rosmake ] Expanded args ['openni_kinect'] to:
['openni_tracker', 'openni_camera', 'depth_image_proc', 'openni_launch', 'openni', 'nite']
[ rosmake ] Generating Install Script using rosdep then executing. This may take a minute, you will be prompted for permissions. . .
Failed to find rosdep nite-dev for package nite on OS:ubuntu version:oneiric
Failed to find rosdep openni-dev for package openni on OS:ubuntu version:oneiric
Failed to find rosdep ps-engine for package nite on OS:ubuntu version:oneiric
[ rosmake ] rosdep install failed: Rosdep install failed                        
chris@chris-VirtualBox:/opt/ros/electric/stacks/openni_kinect$
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2012-07-13 07:24:58 -0500

cagatay gravatar image

updated 2012-07-13 07:29:41 -0500

it has to be

roslaunch openni_launch openni.launch

and also in feurte use

rosdep install package_name

instead of rosmake package_name --rosdep-install

edit flag offensive delete link more
0

answered 2012-07-13 07:36:24 -0500

punching gravatar image

Right, my mistake. I was using that command on the other machine. Was going from memory this time.

I'm on electric and 11.10 now.

I've seen this error message before with the Kinect on the other computer. The latest attempts with the Kinect and it wouldn't even find the device. Now it's finding the Asus but I get the following errors and it hangs at that point.

[ERROR] [1342200800.686674213]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]
[ERROR] [1342200800.696863062]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]
edit flag offensive delete link more

Comments

are you trying to use kinect and asus at the same time ?

cagatay gravatar image cagatay  ( 2012-07-13 07:40:37 -0500 )edit

it seems like two nodes or nodelets are trying to advertise the same topic

cagatay gravatar image cagatay  ( 2012-07-13 07:49:37 -0500 )edit

No. For the last month I've been trying to get the Kinect working. I just got the Asus yesterday. I've also tried installing the OpenNI and Nite drivers manually. I feel like I've tried literally everything.

punching gravatar image punching  ( 2012-07-13 10:10:50 -0500 )edit
0

answered 2012-07-13 10:19:19 -0500

punching gravatar image

http://answers.ros.org/question/10990/problem-starting-openni-in-ros-electric/ - I tried roslaunch openni_camera openni_node.launch and it's the same problem I had a minute ago.

If I tried to run rostopic echo (and for example) /camera/depth/points everything locks. On this computer I'm running Oracle Virtualbox (the other is just straight Ubuntu on an Atom processor) it locks so hard when I run rostopic that I have to reboot the host Windows 7 computer. Damn, it really doesn't want me doing that.

But the upside is that using openni_camera openni_node.launch didn't show any error messages.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-13 07:20:21 -0500

Seen: 759 times

Last updated: Jul 13 '12