Ask Your Question
5

rosdep initialization error

asked 2013-02-03 19:11:24 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have installed Ubuntu 12.10 a day back. And I'm trying to install ROS. I have installed ros-groovy-destop-full. When I try to initialise rosdep, I get error.

sudo rosdep init

ERROR: cannot download default sources list from: ... Website may be down.

But when I copy the address and paste into web browser, the links works. I am running behind proxy (with username/password), so it may be problem of proxy. But I have put proxy details in /etc/apt/apt.conf and apt-get is working fine behind proxy. How do I resolve this issue?

edit retag flag offensive close merge delete

Comments

$ sudo rosdep init

ERROR: cannot download default sources list from: https://raw.github.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list Website may be down.

nehchal gravatar imagenehchal ( 2013-02-03 19:24:25 -0600 )edit
3

As of today, it seems to work with proxies just fine. The key hint is that you need to use `sudo -E rosdep init` to propagate the environmental variables.

cmansley gravatar imagecmansley ( 2014-04-25 06:32:14 -0600 )edit

@cmansley : I get the same error even with the ' sudo -E rosdep init ' Just did a clean install of ROS Indigo, but still can't rosdep init. Same error: ERROR: cannot download default sources list from: ... Website may be down. Any other ideas?

Sergio MP gravatar imageSergio MP ( 2014-09-10 10:36:22 -0600 )edit

I still get this error in 2016 (ubuntu 14.04.2 + ROS indigo). Has anyone been able to find a definitive a solution for this? Proxies didn't solved the problem for me, I still get this error when I try any "rosdep init", "sudo rosdep init" or "sudo -E rosdep init".

marcobecerrap gravatar imagemarcobecerrap ( 2016-05-15 04:28:43 -0600 )edit

5 Answers

Sort by ยป oldest newest most voted
3

answered 2013-02-04 00:26:14 -0600

sebastian gravatar image

Have you tried to configure a system wide proxy in /etc/environment? Add something similar to this to /etc/environment

http_proxy=http://[user:password@]proxy_server:port/
https_proxy=https://[user:password@]proxy_server:port/

I guess rosdep init directly downloads the file from the link and does not use apt to get the file. So your proxy config for apt will not be used...

edit flag offensive delete link more

Comments

Hi, I have followed your instructions ; but still the error exists... Follow the link http://answers.ros.org/question/54924/groovy-error-installation/ Which told us to TRY AGAIN ?

RB gravatar imageRB ( 2013-09-10 02:21:20 -0600 )edit
1

I opened a ticket https://github.com/ros-infrastructure/rosdep/issues/271 to add support for being behind a proxy.

tfoote gravatar imagetfoote ( 2013-09-14 11:57:18 -0600 )edit

Can 'rosdep init / update' be done without connecting to net?

prince gravatar imageprince ( 2014-02-24 22:10:06 -0600 )edit

They both need network resources so no they can not be done offline.

tfoote gravatar imagetfoote ( 2014-05-22 07:23:52 -0600 )edit

For example, if my rasp has: - Username: pi - Password: raspberry - Proxy_server: 192.168.1.100 - Port: 808

I will add:

http_proxy=http://pi:raspberry@192.169.1.100:808/
https_proxy=https://pi:raspberry@192.169.1.100:808/

Is it correct format?

thanhvu94 gravatar imagethanhvu94 ( 2017-03-29 16:49:35 -0600 )edit

Yes. It reads ok.

prince gravatar imageprince ( 2017-04-10 01:24:20 -0600 )edit
12

answered 2017-01-12 08:58:40 -0600

zqpm gravatar image

This wound up being the solution on one system I was using (Jetson TX1 w/ Ubuntu 16.04)

sudo c_rehash /etc/ssl/certs

edit flag offensive delete link more

Comments

thank you, this works for me on a Jetson TX1 too

khaled@neo gravatar imagekhaled@neo ( 2017-03-06 06:13:05 -0600 )edit
tfoote gravatar imagetfoote ( 2017-03-06 15:47:50 -0600 )edit
1

Thanks a lot, it worked for the jetson TX2.

Cyril_J gravatar imageCyril_J ( 2017-04-26 15:08:57 -0600 )edit

Also worked for me, using the Jetson TX2. Thanks a lot

pablini27 gravatar imagepablini27 ( 2018-05-04 13:40:58 -0600 )edit

thanks!! it was good :)

shimjs747 gravatar imageshimjs747 ( 2018-07-23 01:08:48 -0600 )edit
1

answered 2016-05-11 08:18:19 -0600

rohanchauhan gravatar image

sudo -E rosdep init

This command worked for me.

edit flag offensive delete link more

Comments

worked for me too.

Shoeb Ahmed gravatar imageShoeb Ahmed ( 2018-03-16 12:57:02 -0600 )edit
0

answered 2016-05-16 01:43:27 -0600

tfoote gravatar image

You can get this error if you do not have the ssl certificates installed on new python instances.

Try: sudo apt-get install ca-certificates

Related ticket: https://github.com/ros-infrastructure...

edit flag offensive delete link more

Comments

I have checked, and I already have this package installed, but the error remains. I have Ubuntu 14.04 + ros indigo. Ros installation went properly, but I am still unable to initialize rosdep.

marcobecerrap gravatar imagemarcobecerrap ( 2016-05-18 04:10:01 -0600 )edit
0

answered 2018-06-03 01:31:19 -0600

I tried everything mentioned here but what I found is that my system's date was incorrect and as soon as I updated that everything started working normally.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-02-03 19:11:24 -0600

Seen: 25,585 times

Last updated: Jan 12 '17