ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error local network configuration is invalid

asked 2019-10-03 18:44:31 -0500

H.D.P gravatar image

updated 2019-10-04 06:38:29 -0500

gvdhoorn gravatar image

Hi guys

After I went through the beginner tutorial, I encountered problem like this at the end when running roswtf:

Loaded plugin tf.tfwtf
No package or stack in context
Static checks summary:

Found 1 error(s).

ERROR Local network configuration is invalid: Local hostname [lycoris-iv] resolves to [fe80::57c5:c39b:9e1c:5892,2406:3003:206b:238f:3489:6fbb:96ce:2e22,2406:3003:206b:238f:2c9a:1e84:22ef:9f71], which does not appear to be a local IP address ['', ''].

ROS Master does not appear to be running.
Online graph checks will not be run.
ROS_MASTER_URI is [http://localhost:11311]

Have anyone encountered this as well before? I need help T.T

edit retag flag offensive close merge delete


Hello , i have the same problem here .. HELP US i can run roscore successfully yes i tried to disable IPV6 , but still the same problem

Z4K1 gravatar image Z4K1  ( 2019-12-22 07:49:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-10-04 06:40:01 -0500

gvdhoorn gravatar image

IPv6 support in ROS 1 may not be where it should be.

For some reason your host is resolving lycoris-iv to its IPv6 address instead of its IPv4 address.

Or at least: this is what seems to be happening here with roswtf.

Can you run roscore successfully? Or does it also error out with a similar message?

edit flag offensive delete link more


I'd say duplicate of @gvdhoorn's another answer #q291485

130s gravatar image 130s  ( 2019-12-23 21:37:36 -0500 )edit

Question Tools


Asked: 2019-10-03 18:44:31 -0500

Seen: 385 times

Last updated: Oct 04 '19