Ask Your Question
0

error occurred when hokuyo node is launched

asked 2012-12-20 00:22:36 -0500

Kent gravatar image

updated 2012-12-20 00:24:15 -0500

I downloaded the hokuyo node, made it. When I tried to use the "hokuyo_test.launch" file given in the package to launch the hokuyo node, an exception threw out:

[ WARN] [1356005675.931956581]: The use_rep_117 parameter has not been specified and has been automatically set to true.  This parameter will be removed in Hydromedusa.  Please see: http://ros.org/wiki/rep_117/migration
[ERROR] [1356005680.166530146]: Exception thrown while opening Hokuyo.timeout reached (in hokuyo::laser::laserReadline) You may find further details at http://www.ros.org/wiki/hokuyo_node/Troubleshooting

I read the troubleshooting page, but there wasn't any description about "timeout".

edit retag flag offensive close merge delete

Comments

I m actually using a serial usb converter cable, and i set the param “port” as "/dev/ttyUSB0", but i still get the timeout error

Kent gravatar image Kent  ( 2012-12-20 01:22:11 -0500 )edit

Are you running a URG via the serial connection? Why not just use USB directly?

dornhege gravatar image dornhege  ( 2012-12-20 04:15:03 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-05-02 07:40:11 -0500

Ernest gravatar image

Looks like your port isn't set up properly.

I suggest plugging in your LiDAR to a USB port & running the following command to give get rw permissions:

sudo chmod a+rw /dev/ttyACM0
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-12-20 00:22:36 -0500

Seen: 915 times

Last updated: May 02 '13