Ask Your Question
1

Error trying to run hokuyo on groovy

asked 2014-01-15 15:37:06 -0500

Andrew.A gravatar image

updated 2014-02-25 15:07:15 -0500

I haven't used ROS for about a month to two months, and before this, I've managed to get hokuyo working fine. But just yesterday, I tried to use it again but failed. I run roscore, then in a new terminal, run rosrun hokuyo_node hokuyo_node, but I'm faced with an error:

[ERROR] [1389842311.466153862]: Exception thrown while opening Hokuyo.
buffer filled without end of line being found (in hokuyo::laser::laserReadline) You may find further details at <a href="http://www.ros.org/wiki/hokuyo_node/Troubleshooting">http://www.ros.org/wiki/hokuyo_node/Troubleshooting</a>

I've seen the troubleshooting page but my error isn't there. I've also tried to uninstall the package using sudo apt-get remove ros-groovy-laser-drivers and reinstalling it with sudo apt-get install ros-groovy-laser-drivers but that didn't help at all.

Would anyone know what happened? I'm just really puzzled because it worked perfectly before.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2014-01-15 17:01:36 -0500

zero1985 gravatar image

Have you check your port? In default, hokuyo run on /dev/ttyACM0, do you check whether that port is used by some other device?

Let me know if this helps.

edit flag offensive delete link more

Comments

1

Thanks it helped! My /dev/ttyACM0 was arduino.

Andrew.A gravatar imageAndrew.A ( 2014-01-15 17:08:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-15 15:37:06 -0500

Seen: 303 times

Last updated: Jan 15 '14