Ask Your Question
0

Problems with openni_camera + Groovy + Asus Xtion Pro

asked 2012-12-13 04:04:18 -0500

Dave Coleman gravatar image

updated 2016-10-24 09:00:12 -0500

ngrennan gravatar image

Hi, I tried to report this bug in the appropriate issue tracker but I can't find where the Groovy version of OpenNi has been moved. It appears the kforge repo from the documentation is old.

When running "roslaunch openni_launch openni.launch" with an Asus Xtion Pro sensor I can see the image correctly using "rosrun image_view image_view image:=/camera/rgb/image_color". However, the openni node soon seg faults and when I attempt to restart it I get the following errors:

INFO ros.openni_camera./camera/driver: Number devices connected: 1
INFO ros.openni_camera./camera/driver: 1. device on bus 002:04 is a Xtion Pro (600) from ASUS (1d27) with serial id ''
INFO ros.openni_camera./camera/driver: Searching for device with index = 1
INFO ros.openni_camera./camera/driver: No matching device found.... waiting for devices. Reason: openni_wrapper::OpenNIDevice::OpenNIDevice(xn::Context&, const xn::NodeInfo&, const xn::NodeInfo&, const xn::NodeInfo&) @ /tmp/buildd/ros-groovy-openni-camera-1.8.0/debian/ros-groovy-openni-camera/opt/ros/groovy/stacks/openni_camera/src/openni_device.cpp @ 99 : creating depth generator failed. Reason: Got a timeout while waiting for a network command to complete!

And I am unable to reconnect until I restart my computer. Any thoughts on what I need to do to fix this, or what the developers can fix?

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-12-18 16:03:29 -0500

Vincent Rabaud gravatar image

I've never that specific error. Before restarting your computer, can you do a : killall -9 XnSensorServer Are you on USB 1 and 2 ? (not 3) ? Are you on shadow-fixed for Groovy ? Which version of openni-dev do you have installed ?

edit flag offensive delete link more

Comments

The openni drivers have been upgraded so I no longer get this exact error, but it still doesn't work. I'll post a new question.

Dave Coleman gravatar image Dave Coleman  ( 2013-01-04 11:10:18 -0500 )edit
0

answered 2012-12-13 04:18:05 -0500

jcc gravatar image

It's not only in groovy. I have the fuerte with ubuntu 11.10 and i get the same error. Probably some new version of the openni driver...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2012-12-13 04:04:18 -0500

Seen: 930 times

Last updated: Dec 18 '12