Ask Your Question
1

USB events thread - failed to set priority

asked 2016-07-06 11:20:57 -0500

Tamsin gravatar image

I'm following the quick start guide for openni_launch ( http://wiki.ros.org/openni_launch/Tut... ) and I'm having a problem when using OpenNi. I work with Ubuntu 14.04 on a VM and ROS Jade. When I use roslaunch openni_launch openni.launch, I get a warning: USB events thread - failed to set priority. This might cause loss of data...

So when I launch rviz, it detects the device, I can set the fixed frame to /camera_link, the topic of PointCloud2 to /camera/depth/points, but rviz doesn't display any point. When I listen to the topics containing information from the kinect (rostopic echo /camera/rgb/image_color), I can see they exist but no data flows through.

Here are the lines from roslaunch openni_launch openni.launch

started roslaunch server http://ubuntu:34123/

SUMMARY
========

PARAMETERS
 * /camera/camera_nodelet_manager/num_worker_threads: 4
 * /camera/depth_rectify_depth/interpolation: 0
 * /camera/depth_registered_rectify_depth/interpolation: 0
 * /camera/disparity_depth/max_range: 4.0
 * /camera/disparity_depth/min_range: 0.5
 * /camera/disparity_registered_hw/max_range: 4.0
 * /camera/disparity_registered_hw/min_range: 0.5
 * /camera/disparity_registered_sw/max_range: 4.0
 * /camera/disparity_registered_sw/min_range: 0.5
 * /camera/driver/depth_camera_info_url: 
 * /camera/driver/depth_frame_id: camera_depth_opti...
 * /camera/driver/depth_registration: False
 * /camera/driver/device_id: #1
 * /camera/driver/rgb_camera_info_url: 
 * /camera/driver/rgb_frame_id: camera_rgb_optica...
 * /rosdistro: jade
 * /rosversion: 1.11.16

NODES
  /camera/
    camera_nodelet_manager (nodelet/nodelet)
    debayer (nodelet/nodelet)
    depth_metric (nodelet/nodelet)
    depth_metric_rect (nodelet/nodelet)
    depth_points (nodelet/nodelet)
    depth_rectify_depth (nodelet/nodelet)
    depth_registered_hw_metric_rect (nodelet/nodelet)
    depth_registered_metric (nodelet/nodelet)
    depth_registered_rectify_depth (nodelet/nodelet)
    depth_registered_sw_metric_rect (nodelet/nodelet)
    disparity_depth (nodelet/nodelet)
    disparity_registered_hw (nodelet/nodelet)
    disparity_registered_sw (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_hw_registered (nodelet/nodelet)
    points_xyzrgb_sw_registered (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    rectify_ir (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
  /
    camera_base_link (tf2_ros/static_transform_publisher)
    camera_base_link1 (tf2_ros/static_transform_publisher)
    camera_base_link2 (tf2_ros/static_transform_publisher)
    camera_base_link3 (tf2_ros/static_transform_publisher)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[camera/camera_nodelet_manager-1]: started with pid [8916]
process[camera/driver-2]: started with pid [8917]
process[camera/debayer-3]: started with pid [8918]
process[camera/rectify_mono-4]: started with pid [8919]
process[camera/rectify_color-5]: started with pid [8930]
process[camera/rectify_ir-6]: started with pid [8940]
process[camera/depth_rectify_depth-7]: started with pid [8945]
process[camera/depth_metric_rect-8]: started with pid [8967]
process[camera/depth_metric-9]: started with pid [8970]
process[camera/depth_points-10]: started with pid [8986]
process[camera/register_depth_rgb-11]: started with pid [8997]
process[camera/points_xyzrgb_sw_registered-12]: started with pid [9007]
process[camera/depth_registered_sw_metric_rect-13]: started with pid [9013]
process[camera/depth_registered_rectify_depth-14]: started with pid [9019]
process[camera/points_xyzrgb_hw_registered-15]: started with pid [9038]
process[camera/depth_registered_hw_metric_rect-16]: started with pid [9053]
process[camera/depth_registered_metric-17]: started with pid [9056]
process[camera/disparity_depth-18]: started with pid [9062]
process[camera/disparity_registered_sw-19]: started with pid [9071]
process[camera/disparity_registered_hw-20]: started with pid [9090]
process[camera_base_link-21]: started with pid [9093]
process[camera_base_link1-22]: started with pid [9110]
[ INFO] [1467821487.194233892]: Initializing nodelet with 4 worker threads.
process[camera_base_link2-23]: started with pid [9116]
process[camera_base_link3-24]: started with pid [9139]
Warning: USB events thread - failed to set priority. This might cause loss of data...
Warning: USB events thread - failed to set priority. This might cause loss of data...
[ INFO] [1467821490.033406594]: Number devices connected: 1
[ INFO] [1467821490.033934139]: 1. device ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-13 06:27:07 -0500

Dr Roboto gravatar image

It seem to be a kernel issues with some hardware, but you don't need to worry about it too much. here is a link i found about OpenNI and this same warning

https://codeyarns.com/2015/08/05/open...

Cheers ^_^

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-07-06 11:20:57 -0500

Seen: 3,353 times

Last updated: Jun 13 '17