Ask Your Question
1

Missing resource hokuyo_node

asked 2012-11-14 14:14:42 -0500

dan gravatar image

updated 2014-01-28 17:14:16 -0500

ngrennan gravatar image

I am trying to use a Hokuyo rangefinder, following the tutorial, but fail at the first step: rosdep install hokuyo_node rviz

It seems that hokuyo_node is not in ROS_PACKAGE_PATH:

    ERROR: Rosdep cannot find all required resources to answer your query
 Missing resource hokuyo_node ROS path 
    [0]=/opt/ros/fuerte/share/ros ROS path 
    [1]=/home/dbarry/fuerte_workspace/sandbox ROS path 
    [2]=/opt/ros/fuerte/stacks ROS path 
    [3]=/opt/ros/fuerte/share ROS path 
    [4]=/opt/ros/fuerte/share/ros

But hokuyo_node is in what seems an odd spot: /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_plugins/

and adding that path to ROS_PACKAGE_PATH does not help.

I must be missing something obvious, but need help figuring it out. Using Ubuntu 12.04, ROS fuerte

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-11-14 15:28:07 -0500

jbarry gravatar image

The hokoyu_node in gazebo_plugins is just an executable. You are missing the package. You can install it using

sudo apt-get install ros-fuerte-laser-drivers

Or you can install it locally using

rosco hokuyo_node

This requires the rosinstall bundle:

sudo apt-get install python-rosinstall

edit flag offensive delete link more

Comments

Excellent answer! I updated the wiki here: http://www.ros.org/wiki/hokuyo_node/Tutorials/UsingTheHokuyoNode

dan gravatar image dan  ( 2012-11-14 15:44:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-14 14:14:42 -0500

Seen: 358 times

Last updated: Nov 14 '12