Ask Your Question
0

ompl ignores collision

asked 2012-11-07 06:33:25 -0500

viovio gravatar image

updated 2012-11-25 09:14:54 -0500

Hello to all

I builded a package of my Robot (Sträubli TX60L) with the "planning_description_configuration_wizard". Unfortunately the robotarm hits every obstacle on his trajectory (Whether "Planning Components Visualizer" (Obstacles = Poles) or Warehouse Viewer (Obstacles = Boxes)).

parameter dialog of the "warehouse viewer": (http://img198.imageshack.us/img198/7429/planningscenewarehousev.png)

Edit: A collsion-.stl-file: (https://www.rapidshare.com/#!download|539|1254634200|at5_col.stl|1)

Edit: my "Rviz" can only display binary .stl-files, but assimp can only display ASCII stl-files!

I think the problem is the prepended "solid" in my .stl-files like in this threat mentioned:(http://answers.ros.org/question/11569/planning_component_visualizer-bug/) So I also opened my .stl files with wordpad and changed the prepended "solid" to "robot". But now my rviz crashes like in the previous mentioned threat:

Solved: Finally ;) Many Thanks to all supportes, especially yangyangcv. The problem as suggested was the prepended "solid" in the binary .stl-files. It was a bug of pro-engineer. When exporting a non .stl file to a binary .stl pro/e put falsely this "solid" at the beginning, which actually introduces a ascii-.stl-file. Thats the reason why assimp cant open them. After importing and exporting my broken .stl files in Meshlab the solid was taken out and everything worked.

Many Thanks in advance Dominik

edit retag flag offensive close merge delete

Comments

are you using ompl within Planning Components Visualizer and use all the things generated by planning_description_configuration_wizard? if so, it's very weird

yangyangcv gravatar imageyangyangcv ( 2012-11-07 14:54:29 -0500 )edit

yes and yes (I start the visualizer with the package created by the planning_description_configuration_wizard). Any Ideas? Is it possible if my robot violate the collision-check itself (with himself) in the starting-position that ompl ignores collisions in the trajectory planning?

viovio gravatar imageviovio ( 2012-11-08 10:17:09 -0500 )edit

from the warning message, maybe there is something wrong with your stl model file. if it's convenient, send your models files to me and i'll check these files.

yangyangcv gravatar imageyangyangcv ( 2012-11-08 12:48:43 -0500 )edit

Hello yangyangcv, I uploaded a .stl-file on rapidshare (see upper post). Thanks in advance, dominik.

viovio gravatar imageviovio ( 2012-11-13 02:23:03 -0500 )edit

in your post i didn't find the link for your stl file. you can try with other robot models if you have. AFAIK, there is nothing special in the setting of planning_description_configuration_wizard. so i still believe that it's the problem of your robot models.

yangyangcv gravatar imageyangyangcv ( 2012-11-21 00:10:49 -0500 )edit

Sorry for that, I deleted the link meanwhile. Now the Link is in my post again. (https://www.rapidshare.com/#!download|539|1254634200|at5_col.stl|1)

viovio gravatar imageviovio ( 2012-11-22 07:35:40 -0500 )edit

just tried your uploaded stl file. assimpViewer cannot load it. AFAIK, there are two formats for stl: ASCII and binary. your original file is ASCII, that's why assimpViewer cannot load it. so i convert it to binary with 3dsMax and assimpViewer can load it correctly.

yangyangcv gravatar imageyangyangcv ( 2012-11-22 23:23:42 -0500 )edit

Thats weird, in my case its converse. I can open ascII .stl files with assimp. When i try to open a bin stl file assimp says "stl: ASCII files is empty or invalid No data loaded". But if I change all my .stl - Files to binary rviz chrashes.

viovio gravatar imageviovio ( 2012-11-23 02:13:25 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2012-11-13 03:08:45 -0500

AHornung gravatar image

I saw a cylindrical pole in your video. According to this related question that may be a problem with ODE (which is used for collision checking). Replacing the pole with a cylinder mesh or a tall box could resolve the problem.

edit flag offensive delete link more

Comments

To test if thats the problem I loaded my robot-package in the warehouse viewer. There I created a simple box collision object. But the robot still moves through the obstacle - so maybe a option is false set in my arm navigation wizard? Is there a option which occurs on collision detection?

viovio gravatar imageviovio ( 2012-11-19 01:18:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-07 06:33:25 -0500

Seen: 238 times

Last updated: Nov 25 '12