Ask Your Question
0

Top level menu doesn't work on Planning Components Visualizer

asked 2011-10-18 06:56:32 -0500

Hi,

I attended the IROS 2011 workshop on motion planning and went through the tutorials. I wanted to do it again myself and haven't had any problems until I tried to select commands from the top level menu on Planning Components Visualizer. I don't think I had any issues at the workshop just right-clicking "Command..." to display the menu, but it doesn't work on my work environment. I followed the tutorial instructions (http://www.kavrakilab.org/sites/default/files/iros2011_ros_ompl_tutorial.pdf). Do I need to do something else to display the menu other than launching the visualizer at the beginning of Section 6? I ran roswtf and didn't see any errors (although there was 1 warning as below):

$ roswtf
Loaded plugin tf.tfwtf
No package or stack in context
================================================================================
Static checks summary:

No errors or warnings
================================================================================
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
... done running graph rules
running tf checks, this will take a second...
... tf checks complete

Online checks summary:

Found 1 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following nodes are unexpectedly connected:
 * /ompl_planning->/rosout (/rosout)
 * /planning_components_visualizer->/rosout (/rosout)
 * /pr2_test_right_arm_kinematics->/rosout (/rosout)
 * /rviz_planning_components->/rosout (/rosout)
 * /wall_clock_server->/rosout (/rosout)
 * /planning_scene_validity_server->/rosout (/rosout)
 * /trajectory_filter_server->/rosout (/rosout)
 * /rob_st_pub->/rosout (/rosout)
 * /pr2_test_left_arm_kinematics->/rosout (/rosout)
 * /environment_server->/rosout (/rosout)

I'm running Ubuntu 10.04.3 (x86-64) with kernel 2.6.32-34 and using ROS Electric with arm_navigation 1.0.6 and visualization 1.6.4.

edit retag flag offensive close merge delete

Comments

That's all you should need to do. Are you sure that you've selected the "Interact" tab at the top of Rviz - none of the interactive markers will work if you don't select that tab. Are any of the other interactive markers working in the application?
egiljones gravatar imageegiljones ( 2011-10-18 07:01:52 -0500 )edit
Thanks for your quick reply. Yes, I selected the "Interact" tab on Rviz, and the markers showed up. The status of "Interactive Markers" was OK. But, none of the markers weren't working.
tyama gravatar imagetyama ( 2011-10-18 07:11:06 -0500 )edit
Try doing an rm * in the .rviz directory in your home directory. I've seen that fixed problems where interactive markers aren't working at all.
egiljones gravatar imageegiljones ( 2011-10-18 07:31:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-10-18 09:55:10 -0500

updated 2011-10-18 10:06:24 -0500

I ended up reinstalling the visualization stack, but everything works fine now. Thank you very much for your help, egiljones!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-18 06:56:32 -0500

Seen: 392 times

Last updated: Oct 18 '11