Ask Your Question
2

How to fix the motion_planning_rviz_plugin on Fuerte?

asked 2012-05-24 20:10:32 -0500

tor gravatar image

updated 2012-06-08 15:37:20 -0500

Hi All,

I really want to make rviz subscribe to arm_navigation_msgs::DisplayTrajectory and there is already a plugin for that:motion_planning_rviz_plugin in arm_navigation stack. Thanks!

However, there is a typo (an extra 'g') for the class field of class entry in its plugin_description.xml triggering the following error msg when adding Planning Display.

[ERROR] [1337924692.343620701]: The plugin for class 'motiong_planning_rviz_plugin/Planning' failed to load.  Error: Failed to load library /opt/ros/fuerte/stacks/arm_navigation/motion_planning_rviz_plugin/lib/libmotion_planning_rviz_plugin.so. Make sure that you are calling the PLUGINLIB_REGISTER_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Cannot load library: No manifest in /opt/ros/fuerte/stacks/arm_navigation/motion_planning_rviz_plugin/lib/libmotion_planning_rviz_plugin.so: motiong_planning_rviz_plugin__Planning

Based on what I understand from this tutorial, I naively corrected the name field of class entry in plugin_description.xml under /opt/ros/fuerte/stacks/arm_navigation/motion_planning_rviz_plugin. But, I got a segfault when adding Planning Display (Rviz suddenly quit, badly with an _empty_ rviz-*.log).

Still, have no idea why that trivial correction for a seemingly trivial typo in the .xml leads to a segfault.

Do I overlook something?

Thank you.

PS: This is related to this question and this ticket. Apologize for somewhat reposting.

edit retag flag offensive close merge delete

Comments

I can confirm this bug (including the segfault after the naive fix), but I don't know what to do about it. I've updated the relevant bug with a link to this question. Maybe the next step would be to email Gil Jones directly?

Martin Günther gravatar imageMartin Günther ( 2012-06-06 22:12:41 -0500 )edit

Thanks Martin.

tor gravatar imagetor ( 2012-06-07 00:54:43 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2012-06-08 17:17:18 -0500

egiljones gravatar image

Fix for both the type and the segfault released into arm_navigation 1.1.10 - it'll take a couple to get through the build farm and pushed into the public repos (it's already on ros-shadow-fixed for most distros). Let me know if you encounter more problems.

edit flag offensive delete link more

Comments

Thanks Gil.

tor gravatar imagetor ( 2012-06-08 17:52:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-05-24 20:10:32 -0500

Seen: 302 times

Last updated: Jun 08 '12