Ask Your Question
0

Not able to launch kinect on turtlebot ROS fuerte , turtlebot ISO install

asked 2012-10-17 22:20:21 -0600

Vegeta gravatar image

updated 2016-10-24 09:01:52 -0600

ngrennan gravatar image

Hi,

I installed the turtlebot from the ISO supplied by iheartengineering. I am able to run the keyboard teleoperation but unable to launch the kinect to view on the rviz.

I configured everything properly, the installation automatically detected the IP and assigned to the turtlebot. When I run

roslaunch turtlebot_bringup kinect.launch

I got

turtlebot@turtlebot:~$ roslaunch turtlebot_bringup kinect.launch
... logging to /home/turtlebot/.ros/log/935ee6ec-18f7-11e2-bafc-002163c42ffd/roslaunch-turtlebot-25851.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://turtlebot:41913/

SUMMARY
========

PARAMETERS
 * /kinect_laser/max_height
 * /kinect_laser/min_height
 * /kinect_laser/output_frame_id
 * /kinect_laser_narrow/max_height
 * /kinect_laser_narrow/min_height
 * /kinect_laser_narrow/output_frame_id
 * /openni_launch/debayering
 * /openni_launch/depth_frame_id
 * /openni_launch/depth_mode
 * /openni_launch/depth_registration
 * /openni_launch/depth_time_offset
 * /openni_launch/image_mode
 * /openni_launch/image_time_offset
 * /openni_launch/rgb_frame_id
 * /pointcloud_throttle/max_rate
 * /rosdistro
 * /rosversion

NODES
  /
    kinect_breaker_enabler (turtlebot_node/kinect_breaker_enabler.py)
    kinect_laser (nodelet/nodelet)
    kinect_laser_narrow (nodelet/nodelet)
    openni_launch (nodelet/nodelet)
    openni_manager (nodelet/nodelet)
    pointcloud_throttle (nodelet/nodelet)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[kinect_breaker_enabler-1]: started with pid [25877]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[openni_manager-2]: started with pid [25878]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
[ INFO] [1350547767.989473252]: Initializing nodelet with 2 worker threads.
process[openni_launch-3]: started with pid [25900]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[pointcloud_throttle-4]: started with pid [25928]
[ INFO] [1350547768.076326059]: [/openni_launch] No devices connected.... waiting for devices to be connected
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[kinect_laser-5]: started with pid [25944]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[kinect_laser_narrow-6]: started with pid [25963]
[ INFO] [1350547769.100903910]: [/openni_launch] No devices connected.... waiting for devices to be connected
[kinect_breaker_enabler-1] process has finished cleanly
log file: /home/turtlebot/.ros/log/935ee6ec-18f7-11e2-bafc-002163c42ffd/kinect_breaker_enabler-1*.log
[ INFO] [1350547770.121378299]: [/openni_launch] No devices connected.... waiting for devices to be connected
[ INFO] [1350547771.141588971]: [/openni_launch] No devices connected.... waiting for devices to be connected
[ INFO] [1350547772.153494951]: [/openni_launch] No devices connected.... waiting for devices to be connected
[ INFO] [1350547773.170691697]: [/openni_launch] No devices connected.... waiting for devices to be connected
[ INFO] [1350547774.189712549]: [/openni_launch] No devices connected.... waiting for devices to be connected
[ INFO] [1350547775.201424931]: [/openni_launch] No devices connected.... waiting for devices to be connected
^C[kinect_laser_narrow-6] killing on exit
[kinect_laser-5] killing on exit
[pointcloud_throttle-4] killing on exit
[openni_launch-3] killing on exit
[openni_manager-2] killing on exit
[ INFO] [1350547775.993898334]: [/openni_launch] No devices connected.... waiting for devices to be connected
[openni_manager-2] escalating to SIGTERM
shutting down processing monitor...
... shutting down processing monitor complete
done

I tried to check whether the kinect is detectable ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-10-18 03:00:13 -0600

updated 2012-10-18 03:00:55 -0600

This is almost certainly related to your Kinect for Windows. As far as I know, it is still really not supported very well on Linux, and certainly not using standard binaries from ROS repositories. The only chance you'd have would be to run modified source code for the Kinect drivers. If you are interested in doing this, check out @GermanUser and @PatrickMihelich on this thread.

Can you obtain/borrow a standard Xbox Kinect to test on?

edit flag offensive delete link more

Comments

thank you so much ... I have been frustrated trying to make it work. I need to get the xbox kinect now..

Vegeta gravatar imageVegeta ( 2012-10-18 03:01:55 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-17 22:20:21 -0600

Seen: 1,035 times

Last updated: Oct 18 '12