openNI callback registration error [closed]

asked 2012-09-09 11:13:24 -0500

Alec3327 gravatar image

updated 2012-09-09 18:36:45 -0500

jbohren gravatar image

hi, i'm trying to run the hand tracking code ( which is copied from ProrammingGuide document provided by OpenNI) on an ARM dev board (beagleboard_xm) by searching the internet i managed to install OpenNI and Sensorkinect on the board ( using linux ubuntu 12.04 for arm) and the sample code "simpleviewer" works ( it shows the depth of the central point ) However, when i tried the hand tracking code in Openni's PDF programming guide (which needed a fix too i needed to declare a varible in order to compile it) the program exits instead of printing the hand point coordination. i've also tried to run the code by "GDB" debugger and this is the output:

"Program received signal SIGSEGV, Segmentation fault. 0x40052c8a in xnRegisterGestureCallbacks () from /usr/lib/libOpenNI.so"

as it says the problem is in the callback register function... but i've no idea what is causing this... BTW i have tried the code on a laptop (32 bits) and the code works perfectly ( different Openni and sensor source code i did it 3 months ego, i mean i cloned them 3 months ago but the openni running on arm was cloned 2 days ago ). it means the code is working on a 32 bit laptop but not arm.

i'm assuming it has something to do with the compatibility of Openni and SensorKinect that i cloned from github ( i've read somewhere that the new version are not compatible) but the thing is the "simpleviewer" sample code works...

any suggestions ? and i havent installed NITE on the ARM , but i dont think it's needed, is it ? does it have something to do with arm ubuntu ?

(email is line6s3 @ gmail. com)

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by Eric Perko
close date 2012-09-17 17:30:01

Comments

1

This doesn't appear to be ROS-related. If it is, please include the version of ROS you are working against and clarify which openni packages you are using (where did you clone OpenNI and SensorKinect from, etc).

Eric Perko gravatar image Eric Perko  ( 2012-09-09 11:26:00 -0500 )edit

did you try the the openni samples after installing?

dinamex gravatar image dinamex  ( 2012-09-10 01:38:55 -0500 )edit

No updates and still doesn't look ROS-related. I'm closing this as off-topic for now, we can reopen it if @Alec3327 brings it back on-topic by including the ROS-related details.

Eric Perko gravatar image Eric Perko  ( 2012-09-17 17:29:49 -0500 )edit