ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problem with teleop

asked 2012-09-03 02:06:04 -0500

Arjun PE gravatar image

updated 2014-01-28 17:13:32 -0500

ngrennan gravatar image

Hi all,

My teleop didnt work properly in my electric installation. I got the command velocity info that I passed to husky A200. But the problem was, husky didnt move a bit. So I tried to replace the below mentioned three packages with another set of same packages in opt/ros/electric/stacks:-




I also rosmaked all of them. It all went error free. But, when I tried to run:-

roslaunch husky_teleop teleop.launch

It gave me this error :-

ERROR: cannot launch node of type [clearpath_teleop/]: Cannot locate node of type [] in package [clearpath_teleop]

But the node is present, when I checked the location. I also tried to replace the new ones with my old packages. But still the same error persisted.

Any help would be appreciated. Thanks in advance

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-09-03 02:31:50 -0500

Lorenz gravatar image

updated 2012-09-03 02:34:45 -0500

Are you sure that clearpath_teleop is in your ROS_PACKAGE_PATH? Try with roscd clearpath_teleop.

Also, I don't believe this will solve the problem you had according to your previous question. Did you try fixing what I assume to be a networking problem? Otherwise, this node won't work either.

edit flag offensive delete link more

answered 2012-09-03 02:46:37 -0500

Arjun PE gravatar image

updated 2012-09-03 02:46:59 -0500


Yeah clearpath_teleop is my ROS_PACKAGE_PATH. I tried to set ROS_IP and other variables like this :-

export ROS_IP= (WHICH IS HUSKY'S ip)

export ROS_HOSTNAME=cpr-sal-01 (which is husky's name)

export ROS_MASTER_URI=http://cpr-sal-01:11311

I tried the above, but it didnt work. Have I done this correctly ?. Thanks in advance

edit flag offensive delete link more


Please don't create new answers just for discussion. Either use the comment functionality or edit your original answer. ROS_IP must be the ip of your local computer. You don't need to set ROS_HOSTNAME if you have set ROS_IP. Please provide the output of the commands I posted in your other question.

Lorenz gravatar image Lorenz  ( 2012-09-03 02:49:45 -0500 )edit

Question Tools


Asked: 2012-09-03 02:06:04 -0500

Seen: 591 times

Last updated: Sep 03 '12