ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Connection problems with Clearpath Husky

asked 2014-01-14 05:11:14 -0600

Ammar gravatar image

updated 2014-01-28 17:19:01 -0600

ngrennan gravatar image

Hi All, I am trying use the ROS stack for controlling a Husky in ROS Groovy. However when I launch the clearpath_base package with the example.launch file and specify the port as /dev/ttyUSB0 it gives me the following error: [ERROR] [WallTime: 1389718992.689323] Connection error on /dev/ttyUSB* or /dev/ttyS*. Will retry every second.

I have tried using ROS Hydro as well, in this case with the husky_base package and base.launch. I still receive the same error. Could someone please suggest what might be going on here?

edit retag flag offensive close merge delete


I know nothing about the Husky, but can you compare the output of `dmesg` before and after you plug in the robot and list the permission you have on any device that is listed in there.

dornhege gravatar image dornhege  ( 2014-01-14 05:36:35 -0600 )edit

I was able to see the USB in 'dmesg' while plugging it in and out. It had to do with the group permissions. Thanks for the reply!

Ammar gravatar image Ammar  ( 2014-01-16 05:35:23 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-01-16 05:34:26 -0600

Ammar gravatar image

So the problem was that my username was not added to the dialout group. This was causing the USB connection to not send and receive packets from the robot. I ran

sudo gpasspwd -a $USERNAME dialout

where $USERNAME is your Ubuntu username.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-01-14 05:11:14 -0600

Seen: 576 times

Last updated: Jan 16 '14