Ask Your Question
0

gazebo crash when I roslaunch pr2_empty_world

asked 2012-08-28 12:13:02 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I just installed ubuntu 12.04 and ROS fuerte. When I run 'roslaunch pr2_gazebo pr2_empty_world.launch' the entire pr2 model is not showed up on screen.

I only installed ROS and PR2 simulator package. Is there anybody helps me?

The terminal shows following messages:

Segmentation fault (core dumped) Traceback (most recent call last): File "/opt/ros/fuerte/stacks/pr2_mechanism/pr2_controller_manager/scripts/spawner", line 161, in <module> if __name__ == '__main__': main() File "/opt/ros/fuerte/stacks/pr2_mechanism/pr2_controller_manager/scripts/spawner", line 139, in main resp = load_controller(name) File "/opt/ros/fuerte/lib/python2.7/dist-packages/rospy/impl/tcpros_service.py", line 432, in __call__ return self.call(args, *kwds) File "/opt/ros/fuerte/lib/python2.7/dist-packages/rospy/impl/tcpros_service.py", line 522, in call raise ServiceException("transport error completing service call: %s"%(str(e))) rospy.service.ServiceException: transport error completing service call: unable to receive data from sender, check sender's logs for details

[WARN] [WallTime: 1346191217.658283] [0.089000] Spawner couldn't reach pr2_controller_manager to take down controllers.

[gazebo-2] process has died [pid 23235, exit code 139, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gazebo -u /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/worlds/empty.world __name:=gazebo __log:=/home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/gazebo-2.log]. log file: /home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/gazebo-2*.log

[spawn_pr2_model-4] process has finished cleanly log file: /home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/spawn_pr2_model-4*.log

[default_controllers_spawner-24] process has died [pid 24562, exit code 1, cmd /opt/ros/fuerte/stacks/pr2_mechanism/pr2_controller_manager/scripts/spawner --wait-for=/calibrated base_controller base_odometry head_traj_controller laser_tilt_controller torso_controller r_gripper_controller l_gripper_controller r_arm_controller l_arm_controller __name:=default_controllers_spawner __log:=/home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/default_controllers_spawner-24.log].

log file: /home/dpark/.ros/log/bb7462a6-f15b-11e1-acc1-38607740c1c2/default_controllers_spawner-24*.log

edit retag flag offensive close merge delete

Comments

Can you do "unset OGRE_RESOURCE_PATH" and try again? If gazebo still crashes, can you do "roslaunch gazebo_worlds debug.launch" then type "bt" at the gdb prompt after crashing: "(gdb) bt" and post all outputs? thanks.

hsu gravatar image hsu  ( 2012-08-28 13:10:57 -0500 )edit
1

I did "unset OGRE_RESOURCE_PATH". Still it crashes. I also did "roslaunch gazebo_worlds debug.launch". It was not crash. The crash is only happen when I launch pr2 things~ Any suggestions? Thanks

dpark gravatar image dpark  ( 2012-08-29 04:36:52 -0500 )edit

Hi, I am trying to make debugging process easier, can you take a look at this page (http://ros.org/wiki/simulator_gazebo/Troubleshooting) and fill in some more details as mentioned by the second half of the wiki here? Thanks.

hsu gravatar image hsu  ( 2012-08-29 14:05:56 -0500 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2013-05-24 09:41:37 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

[This question is almost a year old, but I still wanted to add my answer].

I also noticed this happening with

roslaunch pr2_gazebo pr2_empty_world.launch

which spawns the PR2 itself, so I tried spawning it myself in an empty world after reducing the solver step size and voilà!

So, while I guess it's not recommended to alter the file I'm about to mention, my solution is nonetheless, the following:

rosed gazebo_worlds empty.world

and change

<dt>0.001</dt>

to something like

<dt>0.0001</dt>

And then, whenever you launch the simulator, you just wait until everything has loaded and just set back the step size to whichever you prefer.

edit flag offensive delete link more
1

answered 2013-11-03 19:28:04 -0500

ljk gravatar image

updated 2013-11-03 19:28:29 -0500

I encountered the same problem and i solved by killing the server and client first and launch again

killall gzclient

killall gzserver
edit flag offensive delete link more

Comments

2020 and this is the only thing that fixed my issue. Thank you

hillripper21 gravatar image hillripper21  ( 2020-07-20 14:12:08 -0500 )edit
0

answered 2012-09-02 13:40:44 -0500

i also met this problem. you can try this instead: roslaunch manipulation_worlds pr2_table_object.launch this works for me. if you want an empty world, you can delete the table and object things in the pr2_table_object.launch. i think it is very straightforward. hope that helps~

edit flag offensive delete link more
0

answered 2012-09-25 05:15:45 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I also have the same problem but with my robot called excavaBOT. In my case, this problem only happen when I launch a controller of base (base_controller, this controller is similar to the controller base of PR2), I also commend you that I've developed other controllers but in this particular controller I have the problem. Besides, it is curious that problem I only met in Fuerte and not in Diamonback. Therefore, I think that the problem is associated with the spawn process of controllers. Anybody has idea about the solution? Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2012-08-28 12:13:02 -0500

Seen: 2,064 times

Last updated: Nov 03 '13