Ask Your Question
0

roslaunch pr2_empty_world.launch not working

asked 2011-03-03 23:56:12 -0500

omwdunkley gravatar image

updated 2012-03-01 20:47:37 -0500

kwc gravatar image

Hey guys,

I am attempting to see the OMPL in action, so I was folling part 6 of the MoveArmJointGoal tutorial.

When I attempt to roslaunch pr2_empty_world.launch gazebo briefly opens, then suddenly closes with some red text left in the console.

Here are the last few lines of the console output:

loading model xml from ros parameter
attempting to spawn robot in simulation
waiting for service spawn_urdf_model
directory [/tmp/gazebo-ollie-0] already exists (previous crash?)
the owner gazebo server (pid=30032) is not running.
deleting the old information of the directory [/tmp/gazebo-ollie-0]
Param [quickStep] is deprecated: [replace quickStep with stepType]
Param [quickStepIters] is deprecated: [replace quickStepIters with stepIters]
Param [quickStepW] is deprecated: [replace quickStepW with stepW]
Gazebo successfully initialized
[ INFO] [1299245159.191944453]: Starting to spin camera_synchronizer at 100.000000 Hz...
[ INFO] [1299245160.622058119, 0.001000000]: INFO: gazebo_ros_laser plugin artifically sets minimum intensity to 101.000000 due to cutoff in hokuyo filters.
Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details
spawning success None
[gazebo-2] process has died [pid 30174, exit code -11].
log files: /home/ollie/.ros/log/ecba1f0e-4662-11e0-92e8-00e09122c142/gazebo-2*.log
[base_hokuyo_node-15] process has died [pid 30307, exit code -11].
log files: /home/ollie/.ros/log/ecba1f0e-4662-11e0-92e8-00e09122c142/base_hokuyo_node-15*.log
[tilt_hokuyo_node-16] process has died [pid 30309, exit code -11].
log files: /home/ollie/.ros/log/ecba1f0e-4662-11e0-92e8-00e09122c142/tilt_hokuyo_node-16*.log
[camera_synchronizer_node-17] process has died [pid 30311, exit code -11].
log files: /home/ollie/.ros/log/ecba1f0e-4662-11e0-92e8-00e09122c142/camera_synchronizer_node-17*.log

Is there anything else I need to do prior to launching? Here are the logs mentioned above:

Running c-turtle installed from the debian packages, ubuntu 10.10, 256MB 8600M, 2.4GHz Core2Duo, 3GB ram, etc. Thanks in advance,

-Oliver

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2011-03-04 05:02:16 -0500

hsu gravatar image

Please see system requirements page to see if your GPU/GPU driver is supported.

If your driver is not on the list, you can check to see if you have direct rendering capability for image sensor simulations and the gazebo gui:

$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions: ...

Without proper GPU support, you can try running headless.

If above doesn't apply, please also post a backtrace for further diagnostics.

Thanks.

edit flag offensive delete link more

Comments

Thanks for your reply hsu. Direct rendering is enabled, and I have had (a while back) some form of a PR2 simulation running in it before (cant remember which one). How exactly do I do this backtrace, and what exactly of? Thanks!
omwdunkley gravatar image omwdunkley  ( 2011-03-05 21:03:30 -0500 )edit
0

answered 2011-11-15 18:21:02 -0500

samsoem gravatar image

I have the same problem with ros electric. I had to install pr2 packages manually after installing the electric-full-desktop or sth. However the gazebo crashes when I launch a non-empty world. I also have the rendering support according to glx. I cannot install diamondback because Iḿ following a tutorial from carfe-o-bot experimentation days.

edit flag offensive delete link more
0

answered 2011-09-25 20:57:02 -0500

Tim Assman gravatar image

updated 2011-09-26 01:26:11 -0500

I had a similar problem under Ubuntu 11.04 with Nvidia Quadro FX 770M.

When I try the spawn PR2 and pendulum tutorials under ros-electric, I get the same error message which kills gazebo: "unable to receive data from sender, check sender's logs for details"

However, I am able to see empty_world.launch in gazebo, and I am sure I have installed the pr2-simulator package. A friend of mine has the same laptop, ubuntu and ros version and gets the same error.

After installing ros-diamondback and sourcing the diamondback setup.bash, the two tutorials mentioned above work. Maybe someone can post in the corresponding wiki's that it only works for ros-diamondback? So if you have a similar problem, try if installing ros-diamondback also solves your problem.

UPDATE: it seems that there is a new release of ros-electric-pr2-desktop, because after reinstalling it 200MB was replaced, the pr2 tutorial works now, the pendulum tutorials are not working yet?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-03 23:56:12 -0500

Seen: 990 times

Last updated: Nov 15 '11