Ask Your Question
1

Ubuntu 12.04 and Pandaboard -> fails to open ASUS xtion/ Driver issues for ARM

asked 2012-08-26 08:41:28 -0500

dinamex gravatar image

updated 2014-01-28 17:13:27 -0500

ngrennan gravatar image

I'm using a Pandaboard which runs Ubuntu 12.04 and I try to use openni_launch. Therefore I need to install the OpenNI drivers. I used the tutorial "Kinect Installation on BeagleBoard-xM and PandaBoard running Ubuntu 12.04" which is pretty good and helped me (and probably a lot more developers) to save some time. Unfortunately, I'm using an Asus xtion (because of the lag of enough usb ports and the fact of less energy consumption). The compiling seems to work well but when I'm trying to run the tutorials I get the following failure msgs: "Open failed: Failed to open the USB device!" By executing the samples as sudo I get following output: "Open failed: Device Protocol: Bad Parameter sent!"

I know that this is probably the wrong forum to ask this question but I know that the robotic community (especially the Raspberry pi owner) are interested to solve this error.

Would be great get your thoughts about this issue. Best regards

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-15 22:57:45 -0500

semael23 gravatar image

For kinect use, i needed to add a udev rule... perhaps you have to this too.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-26 08:41:28 -0500

Seen: 1,039 times

Last updated: Feb 15 '13