Ask Your Question
1

Error: Failed to open port. Permission denied.

asked 2012-08-15 17:19:10 -0500

Hi all, I have been installing Hokuyo UTM-30LX drivers on ROS following sudo apt-get install ros-fuerte-laser-drivers roslaunch hokuyo_node hokuyo_test.launch

as suggested by http://answers.ros.org/question/35022/hokuyo-laser-installation-ubuntu/,

But I came across with the problem Error: Failed to open port. Permission denied.So I found that there is a solution in hokuyo_node/Troubleshooting 1.2 (http://www.ros.org/wiki/hokuyo_node/Troubleshooting) But there is no specific and clear solution for this problem. I don't know how to do it next!!!

Any help is appreciated! Thank you!

edit retag flag offensive close merge delete

Comments

1

In the block that start with SUBSYSTEMS, put that in a file called 99-hokuyo.rules in /etc/udev/rules.d/ There should be similar .rules files there for comparison.

dougbot01 gravatar image dougbot01  ( 2012-08-15 18:40:25 -0500 )edit

That's actually already an answer, you should post it as such.

dornhege gravatar image dornhege  ( 2012-08-15 23:33:34 -0500 )edit

Try chmod first, if that works setup udev as @dougbot01 said.

dornhege gravatar image dornhege  ( 2012-08-15 23:34:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-26 16:51:08 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

From @dougbot01 and @dornhege:

Try using chmod and then in the block that start with SUBSYSTEMS, put that in a file called 99-hokuyo.rules in /etc/udev/rules.d/ There should be similar .rules files there for comparison.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-15 17:19:10 -0500

Seen: 403 times

Last updated: Aug 26 '12