ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Can't launch rqt_robot_steering

asked 2022-09-20 05:52:22 -0600

Joni_07 gravatar image

updated 2022-09-29 02:23:04 -0600

Hey ROS-Community

I want to controll my Robot in Gazebo and launched Gazebo with the command

gazebo

Everything launched fine and I can place my robot in the world at the panel Insert with the command in the .bashrc file:

export GAZEBO_MODEL_PATH=$GAZEBO_MODEL_PATH:/home/joni/dev_ws/src/basic_mobile_robot/models/

So everything went fine and I can set my robot into the enviroment with Insert. See here: image description

I opend a new Terminal and wanted to launch rqt_robot_steering and tipped in:

rqt_robot_steering

and the Error output was :

rqt_robot_steering: command not found

The rqt pkg is installed with the command:

 sudo apt-get install ros-humble-rqt

The output was:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
ros-humble-rqt is already the newest version (1.1.4-1jammy.20220909.020555).
0 upgraded, 0 newly installed, 0 to remove and 27 not upgraded.

So i gues the pkg is installed? My enviroment is sourced with the .bashrcfile lines:

source /opt/ros/humble/setup.bash
export ROS_DOMAIN_ID=1
source /usr/share/colcon_cd/function/colcon_cd.sh
export _colcon_cd_root=/opt/ros/humble/

So what´s wrong? If you want to test or see smth in my enviroment please ask.

Thanks for helping!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2022-09-20 06:13:04 -0600

ravijoshi gravatar image
  1. First, install the package from apt as shown below:

    sudo apt install ros-galactic-rqt-robot-steering
    

    Please change galactic to humble. I have checked it with ROS Galactic and found it working.

  2. Please invoke the node using ROS 2 convention as mentioned below:

    ros2 run rqt_robot_steering rqt_robot_steering
    
edit flag offensive delete link more

Comments

Thanks, my problem was, that I needed to install the rqt_robot_steering node and launch it only with the command:

rqt_robot_steering rqt_robot_steering

Now it works.

Joni_07 gravatar image Joni_07  ( 2022-09-20 06:20:33 -0600 )edit

Glad you made it work. If this answer was helpful, please upvote and click on mark as correct.

ravijoshi gravatar image ravijoshi  ( 2022-09-20 06:22:59 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2022-09-20 05:52:22 -0600

Seen: 1,130 times

Last updated: Sep 29 '22