ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Upgrading from Galactic to Humble

asked 2022-09-15 07:28:42 -0600

shauli_xtend gravatar image

updated 2022-09-15 09:06:40 -0600

ravijoshi gravatar image

Hi all, I am trying to upgrade my ROS2 project from Galactic to Humble. Unfortunately, due to the size of the project I am facing an immense number of errors, most of them related to missing dependencies such as

/opt/ros/humble/include/rclcpp/rclcpp/qos_overriding_options.hpp:28:10: fatal error: rcl_interfaces/msg/set_parameters_result.hpp: No such file or directory

This is usually solved by adding some lines to the CMakeList file (which means the errors is probably valid) such as -

find_package(rcl_interfaces REQUIRED)


What I failed to understand is why everything worked just find with Galactic, while Humble keeps popping those missing header errors. They should have been missing with Galactic, too. Am I doing something wrong?


edit retag flag offensive close merge delete


Can you please tell a bit more about the problem? For example, where did you edit and put find_package code?

ravijoshi gravatar image ravijoshi  ( 2022-09-15 09:05:36 -0600 )edit

Hi @ravijoshi, I added the find_packages in the CMakeLists.txt related to the custom package I created. I am just not sure why weren't they needed when I was using ROS2 galactic.

shauli_xtend gravatar image shauli_xtend  ( 2022-09-15 09:20:43 -0600 )edit

I think some example files are in order

stevemacenski gravatar image stevemacenski  ( 2022-09-16 01:32:52 -0600 )edit

Hi Steve, What example files would you like me to post?

shauli_xtend gravatar image shauli_xtend  ( 2022-09-21 02:57:47 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2023-03-27 16:03:53 -0600

ahopsu gravatar image

updated 2023-03-27 16:04:53 -0600

Hi! I actually faced a similar issue, and in my case I had to add the "missing" dependency for the ament_target_dependencies(), which strangely does not seem to be an issue in Galactic. For example, in my case compiler was complaining about nav2_costmap_2d not being found, and the following addition resolved the issue for me:

image description

edit flag offensive delete link more


Hi ahopsu, Thank you for responding. It does indeed look like something changed in Humble, and after adding many more dependencies, the issue was resolved. Glad it is confirmed by you, too. Hopefully others will find this helpful. Shauli

shauli_xtend gravatar image shauli_xtend  ( 2023-04-09 03:50:50 -0600 )edit

Question Tools

1 follower


Asked: 2022-09-15 07:28:42 -0600

Seen: 484 times

Last updated: Mar 27 '23