Ask Your Question
2

gtest-config

asked 2011-11-25 21:49:53 -0500

Tobias gravatar image

updated 2014-01-28 17:10:52 -0500

ngrennan gravatar image

Hi, I upgraded from diamondback to electric. Compiling my sources with rosmake I get

[rosbuild] Including /opt/ros/electric/stacks/ros_comm/clients/roslisp/cmake/roslisp.cmake [rosbuild] Including /opt/ros/electric/stacks/ros_comm/clients/rospy/cmake/rospy.cmake [rosbuild] Including /opt/ros/electric/stacks/ros_comm/clients/cpp/roscpp/cmake/roscpp.cmake CMake Error at /opt/ros/electric/ros/core/rosbuild/public.cmake:448 (message): Failed to invoke gtest-config

Am I missing a (kubuntu) package? libgtest-dev is already installed on my machine. Unfortunately, it does not contain the gtest-config script.

Any ideas?

Tobias

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
6

answered 2011-11-26 08:49:11 -0500

joq gravatar image

When upgrading from one ROS distribution to the next, it is generally a good idea to completely rebuild any working tree previously compiled using the previous version.

$ rosmake <your_packages> --pre-clean
edit flag offensive delete link more
0

answered 2011-11-26 06:36:54 -0500

Tobias gravatar image

Hi, i had to delete

CMakeCache.txt CMakeFiles/ cmake_install.cmake

. Afterwards, rosmake worked fine again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-25 21:49:53 -0500

Seen: 1,172 times

Last updated: Nov 26 '11