ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

PR2 cannot reset after installing openni_camera

asked 2013-08-06 17:40:52 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi I wanted to use the kinect on PR2 so I installed the openni_camera using sudo apt-get install ros-fuerte-openni-camera. After doing that,I could not reset the robot anymore. The reset option on dashboard turn gray and said could not find motors service. I checked the install log file, it seened many packages were upgraded

Upgrade: ros-fuerte-pr2-apps (0.4.6-s1350956870~lucid, 0.5.0-s1371520863~lucid), ros-fuerte-perception-pcl (1.2.3-s1347138785~lucid, 1.2.5-s1371450432~lucid), ros-fuerte-geometry-experimental (0.2.3-s1347136591~lucid, 0.2.3-s1367528659~lucid), ros-fuerte-warehousewg (0.6.5-s1348594904~lucid, 0.6.5-s1367529042~lucid), ros-fuerte-diagnostics-monitors (1.4.3-s1347136026~lucid, 1.4.3-s1367530209~lucid), ros-fuerte-wge100-driver (1.7.3-s1347143547~lucid, 1.7.3-s1367655289~lucid), ros-fuerte-image-transport-plugins (1.8.2-s1349904048~lucid, 1.8.6-s1367545426~lucid), ros-fuerte-openni-launch (1.8.3-s1349958905~lucid, 1.8.3-s1371476138~lucid), ros-fuerte-robot-model (1.8.1-s1347136194~lucid, 1.8.1-s1367564368~lucid), ros-fuerte-xacro (1.6.1-s1347131788~lucid, 1.6.1-s1367515783~lucid), ros-fuerte-openni-camera (1.8.0-s1347141813~lucid, 1.8.6-s1367546077~lucid), ros-fuerte-pr2-object-manipulation (0.6.4-s1350960994~lucid, 0.6.7-s1371527064~lucid), ros-fuerte-octomap-msgs (0.1.4-0lucid-20120908-1829-+0000, 0.1.4-0lucid-20130502-0929-+0000), ros-fuerte-bullet (2.79-s1347124361~lucid, 2.79-s1367485844~lucid), ros-fuerte-vision-opencv (1.8.8-s1349901092~lucid, 1.8.8-s1367529002~lucid), ros-fuerte-pr2-power-drivers (1.0.9-s1347146212~lucid, 1.0.9-s1367602741~lucid), ros-fuerte-dynamic-reconfigure (1.4.2-s1347131143~lucid, 1.4.2-s1367513777~lucid), ros-fuerte-bond-core (1.6.3-s1347131241~lucid, 1.6.3-s1367513653~lucid), ros-fuerte-nodelet-core (1.6.5-s1347136105~lucid, 1.6.5-s1367529970~lucid), ros-fuerte-filters (1.6.0-s1347135905~lucid, 1.6.0-s1367529933~lucid), ros-fuerte-ros-comm (1.8.15-0lucid-20120908-1754-+0000, 1.8.16-1lucid-20130502-1631-+0000), ros-fuerte-driver-common (1.4.0-s1347139693~lucid, 1.4.0-s1367545209~lucid), ros-fuerte-pr2-common (1.8.2-s1347141195~lucid, 1.8.2-s1367588077~lucid), ros-fuerte-executive-s

I was using the fuerte version. When I switched the system to electric,the robot could run again, but it could not run again when i switched back to fuerte. The problem could have something to do with the upgrades . Could any one faced this problem before and have a solution? Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-08-08 18:05:50 -0600

ahendrix gravatar image

When you installed ros-fuerte-openni-camera, did it remove any other packages?

I suggest trying to reinstall the pr2-core-fuerte, which should reinstall all of the core PR2 packages.

If you're still having trouble, run the PR2 launch file by hand and look for errors in the output: roslaunch /etc/ros/robot.launch

edit flag offensive delete link more


Thanks. I solved the problem by removing all files of openni. It seemed the installation of openni broke other packages.

HanXiao gravatar image HanXiao  ( 2013-08-15 12:33:32 -0600 )edit

Question Tools

1 follower


Asked: 2013-08-06 17:40:52 -0600

Seen: 150 times

Last updated: Aug 08 '13