Ask Your Question
3

openni_node.launch: Warning: recursive print statement has occurred

asked 2011-03-05 12:39:24 -0500

Pi Robot gravatar image

updated 2016-10-24 08:59:46 -0500

ngrennan gravatar image

Not sure if this is a problem or not. On the latest version of the ni stack running on the latest Diamondback and Ubuntu 10.04, I get the following warnings when launching openni_node.launch:

$ roslaunch openni_camera openni_node.launch
core service [/rosout] found
process[openni_node1-1]: started with pid [32041]
process[kinect_base_link-2]: started with pid [32042]
process[kinect_base_link1-3]: started with pid [32043]
process[kinect_base_link2-4]: started with pid [32045]
process[kinect_base_link3-5]: started with pid [32056]
[/openni_node1] Number devices connected: 1
Warning: recursive print statement has occurred.  Throwing out recursive print.
Warning: recursive print statement has occurred.  Throwing out recursive print.
Warning: recursive print statement has occurred.  Throwing out recursive print.
Warning: recursive print statement has occurred.  Throwing out recursive print.
Warning: recursive print statement has occurred.  Throwing out recursive print.

The warning always repeats 5 times as above. The Kinect and the node seem to be working fine, just thought I would report it.

--patrick

edit retag flag offensive close merge delete

Comments

I've got this too. 10.10 on a VirtualBox machine running ontop of ATI video card.
Murph gravatar imageMurph ( 2011-03-10 08:10:05 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2011-03-05 12:59:38 -0500

tfoote gravatar image

Thanks for the report. This sort of thing can go directly into a ticket like this one. https://kforge.ros.org/openni/Trac/ticket/1

edit flag offensive delete link more

Comments

Thanks Tully. Will open a ticket for such things in the future.
Pi Robot gravatar imagePi Robot ( 2011-03-05 13:02:03 -0500 )edit
Please mark answers as "accepted" or "favorite" by clicking the checkbox so they show as answered.
tfoote gravatar imagetfoote ( 2011-03-05 18:04:49 -0500 )edit
0

answered 2011-03-07 08:29:41 -0500

tom gravatar image

I just tried snorri's fix in nodelet.cpp, but it doesn't work for me. I'm on Lucid, Diamondback, downloaded all sources yesterday. That's what I'm getting when trying to launch openni_node.launch (the kinect node won't start):

process[rosout-1]: started with pid [26473]
started core service [/rosout]
process[openni_node1-2]: started with pid [26482]
process[kinect_base_link-3]: started with pid [26487]
process[kinect_base_link1-4]: started with pid [26488]
process[kinect_base_link2-5]: started with pid [26500]
process[kinect_base_link3-6]: started with pid [26511]
[/openni_node1] Number devices connected: 1
Warning: recursive print statement has occurred.  Throwing out recursive print.
Warning: recursive print statement has occurred.  Throwing out recursive print.
[openni_node1-2] process has died [pid 26482, exit code -4].
log files: /home/user/.ros/log/2d2e9de2-4908-11e0-8dde-001d7e94a572/openni_node1-2*.log

The log is not saying all too much:

[roscpp_internal] [2011-03-07 23:13:50,141] [thread 0xb6852a90]: [DEBUG] UDPROS server listening on port [55124]
[roscpp_internal] [2011-03-07 23:13:50,154] [thread 0xb6852a90]: [DEBUG] Started node [/openni_node1], pid [26482], bound on [user-desktop], xmlrpc port [36429], tcpros port [40484], logging to [/home/user/.ros/log/2d2e9de2-4908-11e0-8dde-001d7e94a572/openni_node1-2.log], using [real] time
[roscpp_internal] [2011-03-07 23:13:50,155] [thread 0xb6852a90]: [DEBUG] Shutting down roscpp
[roscpp_internal] [2011-03-07 23:13:50,250] [thread 0xb6852a90]: [DEBUG] Shutting down topics...
[roscpp_internal] [2011-03-07 23:13:50,250] [thread 0xb6852a90]: [DEBUG]   shutting down publishers
[roscpp_internal] [2011-03-07 23:13:50,254] [thread 0xb6852a90]: [DEBUG]   shutting down subscribers
[roscpp_internal] [2011-03-07 23:13:50,255] [thread 0xb6852a90]: [DEBUG] ServiceManager::shutdown(): unregistering our advertised services
[roscpp_internal] [2011-03-07 23:13:50,345] [thread 0xb6852a90]: [DEBUG] UDP socket [8] closed
[roscpp_internal] [2011-03-07 23:13:50,345] [thread 0xb6852a90]: [DEBUG] TCP socket [7] closed
[roscpp_internal] [2011-03-07 23:13:50,360] [thread 0xb6852a90]: [DEBUG] Shutdown finished

Sorry for not using Trac, I don't know how yet. Please let know if I could provide some more info.

edit flag offensive delete link more
0

answered 2011-03-08 20:01:48 -0500

Daniel Stonier gravatar image

Hrm, I just checked the openni_node launcher. There's no nodelets getting run in there. So its either somewhere else making a problem or part of a larger problem.

edit flag offensive delete link more

Comments

Could you please recommend me a temporary fix for this problem? Like, which version number of which stacks I should revert to? I'm planning to cross-compile ROS for ARM in the future so I'd like to work with sources, not debian packages.
tom gravatar imagetom ( 2011-03-08 23:22:50 -0500 )edit
0

answered 2011-03-05 22:57:31 -0500

Daniel Stonier gravatar image

updated 2011-03-05 23:10:00 -0500

I was in the middle of tracking this one down when I saw this pop up on the email. It was in my own code that was upgrading to diamondback and wasn't sure if it was a problem in my own code so I was writing a couple of simple test examples.

Ticketed with a hack of sorts that fixes it here: https://code.ros.org/trac/ros-pkg/ticket/4854.

Actually, looking at this more carefully, this solves the recursive errors on closing down, but not those in startup (I'm getting some of them too). I opened a ticket for that here: https://code.ros.org/trac/ros-pkg/ticket/4855.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-05 12:39:24 -0500

Seen: 881 times

Last updated: Mar 08 '11