Issue with ROS robot running through remote pc, pose is not estimated

asked 2022-06-01 11:24:02 -0500

Rahulwashere gravatar image

updated 2022-06-01 13:34:14 -0500

gvdhoorn gravatar image

Hello, so i have been working for a while on ROS and i am comfortable with ROS simulations, nav-stack tuning & other general parameters. Recently i developed a mobile robot using jetson nano, ros melodic, something similar to NOX_Project . when i run both sensor bring up node(i.e node that launches rplidar, rosserial etc) & navigation node( node that launches amcl, move_base etc) on jetson nano, almost every thing runs fine with occasional warnings of missing the control loop & map update rate! However when i run the navigation node on my laptop(remote pc, after properly configuring the ROS network) my robot runs horribly! . i get the following two errors most often!

[ WARN] [1654086904.698357452]: Costmap2DROS transform timeout. Current time: 1654086904.6982, global_pose stamp: 1654086904.1597, tolerance: 0.5000
[ WARN] [1654086904.721649314]: Could not get robot pose, cancelling reconfiguration

I have tried to fine tune parameters, slow down different loop rates, but i don't think the performance is the issue here as both rviz gui & sensor nodes run finely on jetson nano together. please let me know if any more details are needed

edit retag flag offensive close merge delete


Check the clocks between the two hosts are properly and correctly synchronised.

gvdhoorn gravatar image gvdhoorn  ( 2022-06-01 13:34:35 -0500 )edit

I tried synchronizing both machines by running sudo ntpdate ip_address_of_remote_pc a few times. is there any other way or a better way to do it ? this method was mentioned as a step in Nox project itself!

Rahulwashere gravatar image Rahulwashere  ( 2022-06-01 13:52:06 -0500 )edit

I would suggest to use chrony. It's (briefly) mentioned here: wiki/ROS/NetworkSetup: Timing issues, TF complaining about extrapolation into the future?.

gvdhoorn gravatar image gvdhoorn  ( 2022-06-01 14:34:42 -0500 )edit

HI i tried to follow the link you shared above, the problem still persists

Rahulwashere gravatar image Rahulwashere  ( 2022-06-02 02:51:06 -0500 )edit