Ask Your Question
0

ROS Noetic: problem installer SLAM-TOOLBOX

asked 2022-05-19 11:38:22 -0500

carlo.paniccia gravatar image

updated 2022-05-20 04:35:04 -0500

Hi! Problem: Raspberry Pi4 4GB with OS 20.04. Not install Slam-Toolbox with sudo apt ros-noetic-slam-toolbox. Why?

Thanks! Carlo


pi@raspberrypi:~ $ cd catkin_ws
pi@raspberrypi:~/cd catkin_ws $ sudo apt install ros-noetic-slam-toolbox
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto ros-noetic-slam-toolbox
pi@raspberrypi:~/cd catkin_ws $
edit retag flag offensive close merge delete

Comments

This may seem like a simple question, but have you tried sudo apt install ros-noetic-slam-toolbox? The word install is missing in the above question snippet

ParkerRobert gravatar image ParkerRobert  ( 2022-05-19 21:06:37 -0500 )edit

Thanks for the reply!

Tried sudo apt install ros-noetic-slam-toolbox, but same result: it doesn't find the installation package!

Carlo

carlo.paniccia gravatar image carlo.paniccia  ( 2022-05-20 01:10:24 -0500 )edit

Please add additional information either as a comment, or by editing your question.

Joe28965 gravatar image Joe28965  ( 2022-05-20 03:16:30 -0500 )edit

No, sorry...

Carlo

carlo.paniccia gravatar image carlo.paniccia  ( 2022-05-20 03:30:07 -0500 )edit

That package is available for Ubuntu Focal on ARMv8, but whether you can install it using apt would depend on whether you've used apt to install ROS Noetic itself.

Did you use apt to install ROS Noetic, or did you build from source in a Catkin workspace?

gvdhoorn gravatar image gvdhoorn  ( 2022-05-20 03:34:08 -0500 )edit

I use apt for install ROS Noetic. It is better to redo the whole installation (Ubuntu 20.04 + ROS + SLAM-Toolbox)?

Carlo

carlo.paniccia gravatar image carlo.paniccia  ( 2022-05-20 03:52:19 -0500 )edit

Please show the verbatim output of sudo apt install ros-noetic-slam-toolbox. Do not paraphrase errors / output messages.

gvdhoorn gravatar image gvdhoorn  ( 2022-05-20 03:55:09 -0500 )edit

Et voilà! File dropbox https://www.dropbox.com/s/lxqt64936ku...

Carlo

carlo.paniccia gravatar image carlo.paniccia  ( 2022-05-20 03:59:51 -0500 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2022-05-20 05:04:23 -0500

gvdhoorn gravatar image

updated 2022-05-20 05:15:42 -0500

Raspberry Pi4 4GB with OS 20.04

We apparently all assumed 20.04 meant Ubuntu (which it typically does).

You are however running Raspbian, which is based on Debian Buster:

Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster

That's not 20.04, nor Ubuntu.

Debian Buster only gets packages for ARMv8, but on that platform, according to status_page/ros_noetic_dbv8.html?q=toolb, ros-noetic-slam-toolbox is intentionally not available.

There are no binary packages available for Debian Buster ARMhf (v7, hard-float) at all, therefore, you cannot install slam_toolbox using apt.

Note: it is available for ARMhf for Ubuntu Focal: status_page/ros_noetic_ufhf.html?q=toolb. But that would require you to reinstall your OS.


Edit: I'm rather confused by your statement:

I use apt for install ROS Noetic.

and:

Linux raspberrypi 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l GNU/Linux

Afaict, this would be impossible. Only ARMv8 gets binary packages on Debian Buster.


Edit 2: did you perhaps install ROS using the wiki/UpstreamPackages? If so, please read that page and be aware of the limitations/impact.

edit flag offensive delete link more

Comments

1

Just to answer a potential future question. If you do want to use slam_toolbox you could use a laptop and run it on there, connecting both laptop and raspberry to the same network and configure them to discover each other.

Joe28965 gravatar image Joe28965  ( 2022-05-20 05:10:08 -0500 )edit

Sorry ... which SLAM do you recommend for Raspbian, which is based on Debian Buster?

carlo.paniccia gravatar image carlo.paniccia  ( 2022-05-20 05:13:18 -0500 )edit

Both gmapping and hector_slam seem to be available.

Joe28965 gravatar image Joe28965  ( 2022-05-20 06:06:35 -0500 )edit
0

answered 2022-05-20 03:15:43 -0500

Joe28965 gravatar image

If you run sudo apt update and then try again. Does it work?

Also, does something as simple as sudo apt install ros-noetic-geometry-msgs work?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-05-19 11:38:22 -0500

Seen: 71 times

Last updated: May 20