ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Can't connect crx 10 fanuc robot to Ros

asked 2022-04-17 21:59:28 -0500

nizar00 gravatar image

updated 2022-04-19 01:40:55 -0500

gvdhoorn gravatar image

After installing the fanuc ros driver in the controller , i still can't get the robot to connect to the ROS pc , following the instructions on this page: I run the ROSstate TP program on the pendant I get this screen:

image description

and on the pc i run this command

roslaunch fanuc_crx10ia_support   robot_state_visualize_crx10ial.launch robot_ip:=

i get this output:

[ERROR] [1650255079.236414117]: Parser found 2 elements but 3 expected while parsing vector [0 0 ]
[ERROR] [1650255079.241739007]: Could not parse visual element for Link [link_3]
[ERROR] [1650255079.521415562]: Parser found 2 elements but 3 expected while parsing vector [0 0 ]
[ERROR] [1650255079.522883203]: Could not parse visual element for Link [link_3]

if i run ping using the robot ip i can see its visible:

$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=60 time=4.82 ms

here is the ip setting for the robot:

image description

thanks in advance

edit retag flag offensive close merge delete


Please do not post screenshots of terminals. There is no need, it's all text. Copy-paste it into your question and make sure to format it properly (select the text, click the Preformatted Text button (the one with 101010 on it)).

I've closed your question, as right now it violates the support guidelines. Please edit your question to remove the screenshot and replace it with the actual error text. You can use the edit button/link for that. Do not post a new question.

gvdhoorn gravatar image gvdhoorn  ( 2022-04-18 01:45:00 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2022-04-18 01:43:05 -0500

gvdhoorn gravatar image

updated 2022-04-18 07:33:21 -0500

It's likely this is not a problem with fanuc_driver, but with your URDF/XACRO.

As the error message states:

Parser found 2 elements but 3 expected while parsing vector [0 0 ]. Could not parse visual element for Link [link_3]

Check link_3 in your URDF/XACRO. The origin child of the visual element is likely missing a value there.

Are you using a custom model for the CRX-10iA/L, or the one in fanuc_experimental/fanuc_crx10ia_support? The one in the repository doesn't have any such problem (see here).

Please also note that I believe you are running Ubuntu+ROS in a virtual machine. That may complicate things, as network connections may not be as transparent and bidirectional as they should be. You'll have to check the configuration of your VMs networking. Especially if it's set to NAT, you may have to configure port-forwarding.

edit flag offensive delete link more


Did you get this to work? What was the problem in the end?

gvdhoorn gravatar image gvdhoorn  ( 2022-04-20 00:28:40 -0500 )edit

it works ,it was as you mention due to the URDF file as you mentioned i also changed the settings for the vm just in case

nizar00 gravatar image nizar00  ( 2022-04-20 01:13:40 -0500 )edit

Is there something in the support package of the CRX-10iA we provide in the fanuc_experimental repository that's not working for you? Seeing as you appear to be using an alternative model?

gvdhoorn gravatar image gvdhoorn  ( 2022-04-20 02:55:44 -0500 )edit

the package actually works really well so far but My work wanted to create a simulation using inhouse models so i wanted to base them around this package i can't disclose much more details , thank you for the support

nizar00 gravatar image nizar00  ( 2022-04-20 03:45:35 -0500 )edit

Question Tools

1 follower


Asked: 2022-04-17 21:59:28 -0500

Seen: 358 times

Last updated: Apr 19 '22