ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

[Talos] I am trying to launch talos in simulation but gazebo Segmentation fault (core dumped). [closed]

asked 2022-03-29 15:48:51 -0600

aarsh_t gravatar image

updated 2022-03-29 15:57:43 -0600


I was trying to play with talos robot in simulation. I have installed the simulation using this tutorial in ros-melodic ubuntu 18.04. got some errors but I was able to solve it. I have error free build and all the files have solved missing arguments errors (That I was facing).

when I launch the robot in rviz, it works like a charm. so I thought launching in gazebo to test physics. There were many errors which I was able to solve but one error still remains at the end.

[ INFO] [1648586058.460195637, 30.401000000]: gazebo_ros_control plugin is waiting for model URDF in parameter [robot_description] on the ROS param server.
Segmentation fault (core dumped)
================================================================================REQUIRED process [gazebo-2] has died!
process has died [pid 16089, exit code 139, cmd /home/aarsh/henrique_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/gzserver -e ode worlds/ __name:=gazebo __log:=/home/aarsh/.ros/log/83708ae4-af9f-11ec-87e7-ac2b6e45babe/gazebo-2.log].
log file: /home/aarsh/.ros/log/83708ae4-af9f-11ec-87e7-ac2b6e45babe/gazebo-2*.log
Initiating shutdown!
[rgbd/rgb/image_proc-5] killing on exit
[rgbd/rgb/high_res/image_proc_high_res-4] killing on exit
[gazebo-2] killing on exit
[gazebo_gui-3] killing on exit
Segmentation fault (core dumped)

NOTE : There is the /robot_description parameter present in the param list.

So I removed the from this file and tried to launch it again and it works without the It is not at all the issue of the tags inside the plugin <ns></ns> <robotSimType>pal_hardware_gazebo/PalHardwareGazebo</robotSimType> <robotNamespace></robotNamespace> <controlPeriod>0.001</controlPeriod> I have tried removing all of them and still I get the same error.

When I remove the whole plugin, it works perfectly. Just robot falls down due to gravity.

Let me know if you need any further info.

Thank you for helping.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by aarsh_t
close date 2022-06-29 03:12:05.636463


Hello, This could be the gazebo_ros_control plugin provided by PAL Robotics, is not properly compiled in your workspace. I recommend you to clean your workspace and build again and also check for any running gazebo servers in the background and kill them before launching the simulation. You can also open an issue in the GitHub repository : with the issues you faced and resolved on your own, so we can take a look.

saikishor gravatar image saikishor  ( 2022-03-29 15:57:42 -0600 )edit

Hello sir, Thank you for your inputs, I will try to do the suggested and will report the updates.

aarsh_t gravatar image aarsh_t  ( 2022-03-30 09:28:22 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2022-04-01 14:55:38 -0600

aarsh_t gravatar image

updated 2022-04-01 15:02:35 -0600

I figured out the issue, Pal is using modified ros_controller and the transmission_interface package. hence they are using the boost shared pointer and not the std shared pointer (which is used in the ros kinetic and above). I thought the ros_controller comes with talos simulation is the same that comes in melodic so I did not built it, but its not the same. it is modified one.


edit flag offensive delete link more


@aarsh_t at PAL Robotics we use the ROS Control with some custom fixes and features on our end. Unless you compile the the ros_control packages as per the . rosinstall, you might have troubles testing some controllers. If not change the gazebo plugin and things might work.

saikishor gravatar image saikishor  ( 2022-04-01 14:58:14 -0600 )edit

Aha I see! I tried to fixed the shared pointer things for one of the package and it built successfully but I didn't knew you have also modifications from your side. Well, nice to learn something new! now I might dig the modifications from the original package as well haha. Thanks for the info ;)

aarsh_t gravatar image aarsh_t  ( 2022-04-01 15:01:54 -0600 )edit

Question Tools

1 follower


Asked: 2022-03-29 15:48:51 -0600

Seen: 92 times

Last updated: Apr 01 '22