ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

URDF and RVIZ2: cylinder not showing

asked 2021-11-03 10:46:17 -0600

laziest_robot gravatar image


I am working through the urdf_tutorials and I found that rviz doesn't show the cylinder model correctly, it only shows the circle on the floor and isn't 'extruded'. The box and sphere work fine and are shown in rviz. There aren't any errors shown in the terminal.

Link to rviz display

I am using: ROS2 - galactic, RVIZ2 version Alpha

Packages: joint_state_publisher joint_state_publisher_gui

OS: Ubuntu 20.04.3 LTS 64bit with kernel 3.36.8

It looks like this is a bug in the parser? Thanks for the help!

edit retag flag offensive close merge delete



Looks like a repeat question. Take a look at

osilva gravatar image osilva  ( 2021-11-03 21:25:31 -0600 )edit

Thanks osilva, putting LC_NUMERIC="en_US.UTF-8" to .bashrc solved my issue.

echo 'export LC_NUMERIC="en_US.UTF-8"' >>~/.bashrc

laziest_robot gravatar image laziest_robot  ( 2021-11-04 04:28:45 -0600 )edit

Glad to hear it worked

osilva gravatar image osilva  ( 2021-11-04 05:26:07 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2021-12-18 02:54:42 -0600

laziest_robot gravatar image

Putting LC_NUMERIC="en_US.UTF-8" to .bashrc solved my issue:

echo 'export LC_NUMERIC="en_US.UTF-8"' >>~/.bashrc

I have adjusted the ROS2 documentation to include this step. Pull Request

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2021-11-03 10:45:23 -0600

Seen: 391 times

Last updated: Dec 18 '21