RobotState "no msg received" but robot moving slightly while "Execute" is still running in Rviz

asked 2021-10-23 05:32:38 -0500

Josh98 gravatar image

updated 2021-10-26 08:53:29 -0500

lucasw gravatar image

I'm running Ubuntu 20.04.3 LTS (Kernel: 5.14.13-surface x86_64) on a Microsoft Surface Book 2. My ros distro is noetic.

First of all I am still very new to ROS and have already learned a lot and fixes many issus myself but this one I cant figure out. I am trying to solve this issue for several weeks now and I don't make any progress... I am trying to build a custom 6DOF robot model controlled by Moveit via USB. I have successfully generated a URDF file using the fusion2urdf script for Fusion360. After that I used the moveit_setup_assistant to create all the necessary files moveit needs to run. During my whole project I was mainly following a YouTube tutorial series from "stephen zuccaro" (Creating your Moveit Hardware Interface - C++) to create my hardware interface using the ros_control_boilerplate from PickNikRobotics. After a lot of trail and error I was finally able to successfully launch rviz. My robot shows up and I can use MotionPlanning to generate joint angles on the /joint_states topic. I have no errors during the startup of my main launch file except for this one:

[ERROR] [1634931694.555060870]: Tried to advertise on topic [/move_group/filtered_cloud] with md5sum [060021388200f6f0f447d0fcd9c64743] and datatype [sensor_msgs/Image], but the topic is already advertised as md5sum [1158d486dd51d683ce2f1be655c3c181] and datatype [sensor_msgs/PointCloud2]

The problem is that when I hit "Plan and Execute" the "grey" robot in Rviz is just moveing very slightly and stops as soon as the execution is "successfully" finished. So the next time I try to move the robot it starts calculating the joint angles based on the same starting pose as when rviz just launched. When I add "RobotState" to the "Displays" section it says: "No msg received". If i run

rosrun tf2_tools

I get a pdf file whis only says "no tf data recieved".

roswtf is giving me the following output:

Loaded plugin tf.tfwtf
No package or stack in the current directory
Static checks summary:

No errors or warnings
Beginning tests of your ROS graph. These may take a while...
analyzing graph...
... done analyzing graph
running graph rules...
... done running graph rules
running tf checks, this will take a second...
... tf checks complete

Online checks summary:

Found 2 warning(s).
Warnings are things that may be just fine, but are sometimes at fault

WARNING The following node subscriptions are unconnected:
 * /robot_hw_main:
   * /position_trajectory_controller/command
 * /move_group:
   * /collision_object
   * /head_mount_kinect/depth_registered/points
   * /head_mount_kinect/depth_registered/image_raw
   * /head_mount_kinect/depth_registered/camera_info
   * /sequence_move_group/goal
   * /sequence_move_group/cancel
 * /rviz:
   * /recognized_object_array
   * /display_robot_state

WARNING These nodes have died:
 * ros_control_controller_manager-4

Can anyone explain to me why my robot is moving even tough /tf is not receiving anything?

Here is my launch file


 <!-- RVIZ  -->

    <!-- Load the URDF to the parameter server -->
    <param name="robot_description" textfile="$(find roboturdf_description)/urdf/roboturdf.urdf"/>

    <!-- Show in Rviz  -->
    <node name="rviz" pkg="rviz" type="rviz" args="-d $(find robot_control)/basic.rviz"/>

 <!-- CORE  -->

  <!-- Load controller settings  -->
    <rosparam file ...
edit retag flag offensive close merge delete