ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
7

Cannot locate node of type [state_publisher]

asked 2020-07-20 15:26:16 -0600

nodigue gravatar image

updated 2021-04-24 02:38:09 -0600

miura gravatar image

Currently running ROS Noetic (installed with apt) on Debian 10, I tried to follow the URDF tutorial : http://wiki.ros.org/urdf/Tutorials/Us....

However I get the following error message when launching the display.launch file :

ERROR: cannot launch node of type [robot_state_publisher/state_publisher]: Cannot locate node of type [state_publisher] in package [robot_state_publisher]. Make sure file exists in package path and permission is set to executable (chmod +x)

I tried every other solution I could find online but nothing works for me... Maybe I missed something.

Thanks in advance !

edit retag flag offensive close merge delete

Comments

do you have the package correctly installed?

Try:

sudo apt-get install ros-noetic-robot-state-publisher
Solrac3589 gravatar image Solrac3589  ( 2020-07-21 06:01:50 -0600 )edit

1 Answer

Sort by » oldest newest most voted
29

answered 2020-07-21 13:09:56 -0600

sloretz gravatar image

state_publisher was a deprecated alias for the node named robot_state_publisher. It was removed in https://github.com/ros/robot_state_pu... which is included in the ROS Noetic release of that package. Change type="state_publisher" to type="robot_state_publisher".

<!-- Change state_publisher  -->
<!-- <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher" /> -->
<!-- To robot_state_publisher -->
<node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" />

I updated the tutorial.

edit flag offensive delete link more

Comments

1

Thanks ! It works now :)

nodigue gravatar image nodigue  ( 2020-07-21 13:36:01 -0600 )edit

Thanks. It works perfectly now.

deficos gravatar image deficos  ( 2022-03-16 01:29:06 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-07-20 15:26:16 -0600

Seen: 10,220 times

Last updated: Jul 21 '20