AR 2.0 Drone not taking off after sending an empty meassgae to /ardrone/takeoff topic

asked 2021-08-30 09:41:38 -0600

I am using a docker container which has ROS indigo. I installed the ardrone_autonomy package successfully and I am able to read the sensor data (/ardrone/imu , /ardrone/odometry) for example. However when I send an empty message to the /ardorne/takeoff topic the drone does not take off, the same happens with when writing to the /cmd_vel topic (the propellers do not rotate). I suspected that the drone firmware is the issue (2.4.x , x>10). The documentation mentions that the package is based on AR-Drone SDK version 2.0.1. So, I tried to downgrade the frame following this link ( I noticed that after writing the update file to the drone through the ftp session, when I remove and reconnect the battery nothing changes. I am still not able to fly the drone, any help would be appreciated.

edit retag flag offensive close merge delete


ma7_bakr gravatar image ma7_bakr  ( 2021-09-01 02:20:37 -0600 )edit